Jump to content
Sign in to follow this  
ponko

Oscam werkt niet meer wanneer de server in standby staat

Recommended Posts

13 minuten geleden zei sattv4iedereen:

Mijn server box staat bijna altijd standby met mijn cd kaart  naar de zero 4K met je genoemde protocol en dat werkt.

Ben je zeker, dat je server na een tijd niet naar deep standby gaat?

Vroeger had ik ook je probleem,  en dat was mijn probleem. In het afsluit menu stond  er na een aantal uren geen reactie ga naar deep standby. Was in pli, maar draai nu vti.

Ik heb ook VTI draaien, in welk afsluit menu bedoel je?

Stond dat ergens in een config of was het de image van PLI?

Share this post


Link to post
Share on other sites

afsluitmenu moet je natuurlijk helemaal niet gebruiken

als de server met de afstandbediening een korte druk op rode knop krijgt is die al onmiddellijk standby

en dan zie je geen beeld meer op je TV maar alles (de applicaties) werkt op de achtergrond gewoon verder

Share this post


Link to post
Share on other sites
14 uur geleden zei sattv4iedereen:

Mijn server box staat bijna altijd standby met mijn cd kaart  naar de zero 4K met je genoemde protocol en dat werkt.

je zevert ook maar wat, toch?

gisteren schrijf je nog dat je maar een VU ter beschikking hebt in een ander topic!

en nu heb je een server met CD kaart rara?

Share this post


Link to post
Share on other sites

 

Kan hem vaak niet goed volgen... Lijkt wel of hij vaak verhuisd. Dan weer Telenet, dan weer FritzBox, dan weer TVV...

Misschien dat hij veel 'troep' krijgt om te testen van kennissen/vrienden... Geen idee.

In elk geval leest hij niet (of het dringt niet door) en vraagt hij vaak in het wilde weg..

 

Share this post


Link to post
Share on other sites

Denk ik ook, maar één server moet 24/7 aan blijven... dus minimaal standby voor die receiver met oscam werkende als server.

Hoe de fout ontstaan is bij de client kan ik niet zo een twee drie zeggen ondanks een redelijk makkelijk en standaard CCcam lijntje / protocol.

Misschien use own cards foutje...?

 

Share this post


Link to post
Share on other sites

goedenavond,

 

Ik heb de oplossing voor mijn probleem eindelijk gevonden.

Het heeft te maken met de instellingen van de clientmaxidle instellingen van oscam.

Zie onderstaande tekst;

 

This is not a bug but a willing issue by the concerned dev. He forgot that by changing a default he could screw up other protocols then cs378x. Which he did.
Since very long keepalive was inserted specially for cccam and only for cccam by a cccam client account (is in oscam.user) . This parameter just overides the default oscam value in oscam.conf section and sets it to 0. disabled.
[global]
clientmaxidle = 120 (120 sec is default value if not present in configs 120 sec it will be)
By changing the default value of umaxidle in the client account from 0 to -1 (-1 means : take value of oscam.conf the keepalive function in to the account is simply disabled. and each 2 minutes (120 sec) client will be disconnected. If clientmaxidle = 0 no disconnection will occur. If You set an other value for example 60 seconds each 60 seconds a client will be disconnected.
What to do .
To be shure off all set :
oscam.conf
[global]
clientmaxidle = 0 (non default value)
[cccam]
keepconnected = 1
[oscam.user]
umaxidle = 0 (non default value) But before svn9799 it was the default value and should never have been changed.
For you're connections to another cccam server set by
[oscam.server]
ccckeepalive = 1
And you never will have a disconnect problem anymore.
The continious disconnect and recconect indeed does fill up ram and ends by blocking the whole stb in pretty short time.
comment:23Changed 5 jaar ago by Poedel
Thanks stefansat for clearing this out! So we don't need the keepalive setting at the user anymore? While it's not mentioned here (in [oscam.user] section, keepalive = 1):
oscam.conf
clientmaxidle = 0
[cccam]
keepconnected = 1
[oscam.user]
umaxidle = 0
[oscam.server]
ccckeepalive = 1
comment:24Changed 5 jaar ago by Poedel
Also it's seems to be useless to set umaxidle = 0 in oscam.user, when you set clientmaxidle = 0 in oscam.conf:
umaxidle = seconds
value for user being idle before disconnect.
-1 = use clientmaxidle in [global]-section
0 = idle disconnect disabled (default) (Wiki should be changed here, while -1 is the default now)
Or am I wrong and should umaxidle be set to 0 to prevent disconnects? And when we set umaxidle to 0, should we still use the keepalive setting at the user or is this also useless then?
Last edited 5 jaar ago by Poedel (vorige) (diff)
comment:25Changed 5 jaar ago by stefansat sat
Yes I forgot the keepalive = 1 by the user account into oscam.user.
At this moment i'm not using cccam protocol anymore. But if You set clientmaxidle = 0 Do not think that keepalive = 1 is needed by the oscam.user. It was made to override the clientmaxidle.(but not the umaxidle).
comment:26Changed 5 jaar ago by Poedel
But why to set umaxidle = 0 at the user, when you set clientmaxidle = 0 in oscam.conf, which is the maxidle setting for all users?!
comment:27Changed 5 jaar ago by stefansat sat
Oplossing:    → invalid
Status:    reopened → closed
Indeed if clientmaxidle = 0 it's not needed to change the default umaxidle = -1

 

 

Share this post


Link to post
Share on other sites
13 uur geleden zei ponko:

goedenavond,

 

Ik heb de oplossing voor mijn probleem eindelijk gevonden.

Het heeft te maken met de instellingen van de clientmaxidle instellingen van oscam.

Zie onderstaande tekst;

 

This is not a bug but a willing issue by the concerned dev  ………………………………………...bla, bla, bla ……….

 

Wat stond er dan bij jou verkeerd ? en/of heb je het echt kunnen oplossen ?

Share this post


Link to post
Share on other sites

Die rare settings heb ik nooit gezien in mijn config… Bouw hem zelf en ook altijd op de laatste verise (niet omdat het moet, maar omdat het kan).. Nooit problemen gehad met rare disconnects...

Share this post


Link to post
Share on other sites
Op 31-10-2019 om 10:55 zei Tonskidutch:

je zevert ook maar wat, toch?

gisteren schrijf je nog dat je maar een VU ter beschikking hebt in een ander topic!

en nu heb je een server met CD kaart rara?

Ik had het over vroeger hë. En ik heb nog een vu met kabeltuner.

ik heb het over pli, maar uiteraard hoef je nier in afsluitmenu gaan, maar daar stond iets in van deep standby na enige tijd.

Share this post


Link to post
Share on other sites

Ik heb de regel in oscam config aangepast, client max idle =0. Deze stond op -1

Het schijnt dat deze regel in de vorige oscam versies standaard op 0 staan maar bij de laatste oscam versies staat deze op -1.

Sinds ik het heb aangepast heb ik nog geen problemen meer gehad.

Het viel mij op toen de verbinding weer een keer weg was dat er in de logfile “ user ultimo4k reached 120 sec idle limit” stond.

Daar ben ik op gaan zoeken op google en zodoende had ik dit gevonden.

Had hier nooit eerder problemen mee wanneer de ontvangers in standby werden gezet kon ik de volgende dag gewoon verder kijken en nu werd de verbinding niet weer opgepakt.

Zie hieronder mijn oscam config;

 

[global]
disablelog                    = 1
logfile                       = /tmp/oscam.log
pidfile                       = /tmp/oscam.pid
clientmaxidle                 = 0
unlockparental                = 1
nice                          = -10
maxlogsize                    = 100
waitforcards                  = 0
preferlocalcards              = 2
usrfile                       = /tmp/user.log
cwlogdir                      = /var/log/
emmlogdir                     = /var/log/

[cache]

[cs357x]
port                          = 14550
serverip                      = 192.168.178.52

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 0
user                          = dvbapi_local
boxtype                       = dreambox

[webif]
httpport                      = 83
httpallowed                   = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.0.255,255.255.255.255
httposcamlabel                = Oscam WebInterface

 

Edited by ponko

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Onze Terms of Use en Privacy Policy