Jump to content

Oscam start/stop script vraag


MySat
 Share

Recommended Posts

Ben bezig om mijn server te upgraden en heb hiervoor een nieuw script gebruikt. Dit werkt slechts gedeeltelijk want mijn parameters voor de oscam.conf file worden niet meegenomen in het script en dat begrijp ik niet helemaal

 

Het script

 

#! /bin/sh
### BEGIN INIT INFO
# Provides:          Oscam
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Oscam init script
# Description:       Launch oscam at startup
### END INIT INFO

 

DAEMON=/emu/bin/oscam
DEAMON_OPTS="-b -c /emu/conf/ -r 2"
PIDFILE=/var/run/oscam.pid
 
test -x ${DAEMON} || exit 0
 
. /lib/lsb/init-functions
 
case "$1" in
    start)
 log_daemon_msg "Starting OScam"
 start-stop-daemon --start --quiet --background --pidfile ${PIDFILE} --make-pidfile --exec ${DAEMON} -- ${DAEMON_OPTS}
 log_end_msg $?
    ;;
    stop)
 log_daemon_msg "Stopping OScam"
 start-stop-daemon --stop --exec ${DAEMON}
 log_end_msg $?
    ;;
    force-reload|restart)
    $0 stop
    $0 start
    ;;
  *)
    echo "Usage: /etc/init.d/oscam {start|stop|restart|force-reload}"
    exit 1
    ;;
esac
 
exit 0

 

Einde script

 

Mijn configuratie file staat in de dir /emu/conf. Indien ik vanaf de cmdline #./oscam -b -c /emu/conf/ -r 2 ingeef, start oscam conform verwachting, maar via het script slaat het mijn config file over...

 

RaRa..

 

 

 

Niks is geheim in deze wereld, ik weet alleen soms niet waar of van wie ik de juiste informatie kan krijgen


+++ 4 x VU solo SE /  T90 / 7 Quad LNB's / OpenPli / Latest Oscam / Raspberry / Strong SRT7404 (op de plank voor de jaarlijkse update ) +++

Link to post
Share on other sites


DEAMON_OPTS="-b -c /emu/conf/ -r 2"
 start-stop-daemon --start --quiet --background --pidfile ${PIDFILE} --make-pidfile --exec ${DAEMON} -- ${DAEMON_OPTS}

Opties gezet in DEAMON_OPTS

Je stuurt DAEMON_OPTS

  • Like 1
Link to post
Share on other sites

Top! Deze had ik niet opgemerkt. Lijkt me het probleem idd. Script aangepast en een reboot gedaan. Opgelost. Jammer dat ik de website niet meer kan terughalen. Dit was een copy/past actie.

Niks is geheim in deze wereld, ik weet alleen soms niet waar of van wie ik de juiste informatie kan krijgen


+++ 4 x VU solo SE /  T90 / 7 Quad LNB's / OpenPli / Latest Oscam / Raspberry / Strong SRT7404 (op de plank voor de jaarlijkse update ) +++

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Lees alvorens je verder gaat onze Terms of Use en Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.