Ga naar inhoud

ponko

Leden
  • Aantal items

    15
  • Registratiedatum

  • Laatst bezocht

Over ponko

  • Titel
    Proef lidmaatschap
  • Verjaardag 06/17/1972

Aanvullende info

  • Geslacht
    Mannelijk
  • Interesses
    VU+Ultimo, VU+Uno, VU+Ultimo4K
  1. Ik heb de regel in oscam config aangepast, client max idle =0. Deze stond op -1 Het schijnt dat deze regel in de vorige oscam versies standaard op 0 staan maar bij de laatste oscam versies staat deze op -1. Sinds ik het heb aangepast heb ik nog geen problemen meer gehad. Het viel mij op toen de verbinding weer een keer weg was dat er in de logfile “ user ultimo4k reached 120 sec idle limit” stond. Daar ben ik op gaan zoeken op google en zodoende had ik dit gevonden. Had hier nooit eerder problemen mee wanneer de ontvangers in standby werden gezet kon ik de volgende dag gewoon verder kijken en nu werd de verbinding niet weer opgepakt. Zie hieronder mijn oscam config; [global] disablelog = 1 logfile = /tmp/oscam.log pidfile = /tmp/oscam.pid clientmaxidle = 0 unlockparental = 1 nice = -10 maxlogsize = 100 waitforcards = 0 preferlocalcards = 2 usrfile = /tmp/user.log cwlogdir = /var/log/ emmlogdir = /var/log/ [cache] [cs357x] port = 14550 serverip = 192.168.178.52 [dvbapi] enabled = 1 au = 1 pmt_mode = 0 user = dvbapi_local boxtype = dreambox [webif] httpport = 83 httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.0.255,255.255.255.255 httposcamlabel = Oscam WebInterface
  2. goedenavond, Ik heb de oplossing voor mijn probleem eindelijk gevonden. Het heeft te maken met de instellingen van de clientmaxidle instellingen van oscam. Zie onderstaande tekst; This is not a bug but a willing issue by the concerned dev. He forgot that by changing a default he could screw up other protocols then cs378x. Which he did. Since very long keepalive was inserted specially for cccam and only for cccam by a cccam client account (is in oscam.user) . This parameter just overides the default oscam value in oscam.conf section and sets it to 0. disabled. [global] clientmaxidle = 120 (120 sec is default value if not present in configs 120 sec it will be) By changing the default value of umaxidle in the client account from 0 to -1 (-1 means : take value of oscam.conf the keepalive function in to the account is simply disabled. and each 2 minutes (120 sec) client will be disconnected. If clientmaxidle = 0 no disconnection will occur. If You set an other value for example 60 seconds each 60 seconds a client will be disconnected. What to do . To be shure off all set : oscam.conf [global] clientmaxidle = 0 (non default value) [cccam] keepconnected = 1 [oscam.user] umaxidle = 0 (non default value) But before svn9799 it was the default value and should never have been changed. For you're connections to another cccam server set by [oscam.server] ccckeepalive = 1 And you never will have a disconnect problem anymore. The continious disconnect and recconect indeed does fill up ram and ends by blocking the whole stb in pretty short time. comment:23Changed 5 jaar ago by Poedel Thanks stefansat for clearing this out! So we don't need the keepalive setting at the user anymore? While it's not mentioned here (in [oscam.user] section, keepalive = 1): oscam.conf clientmaxidle = 0 [cccam] keepconnected = 1 [oscam.user] umaxidle = 0 [oscam.server] ccckeepalive = 1 comment:24Changed 5 jaar ago by Poedel Also it's seems to be useless to set umaxidle = 0 in oscam.user, when you set clientmaxidle = 0 in oscam.conf: umaxidle = seconds value for user being idle before disconnect. -1 = use clientmaxidle in [global]-section 0 = idle disconnect disabled (default) (Wiki should be changed here, while -1 is the default now) Or am I wrong and should umaxidle be set to 0 to prevent disconnects? And when we set umaxidle to 0, should we still use the keepalive setting at the user or is this also useless then? Last edited 5 jaar ago by Poedel (vorige) (diff) comment:25Changed 5 jaar ago by stefansat sat Yes I forgot the keepalive = 1 by the user account into oscam.user. At this moment i'm not using cccam protocol anymore. But if You set clientmaxidle = 0 Do not think that keepalive = 1 is needed by the oscam.user. It was made to override the clientmaxidle.(but not the umaxidle). comment:26Changed 5 jaar ago by Poedel But why to set umaxidle = 0 at the user, when you set clientmaxidle = 0 in oscam.conf, which is the maxidle setting for all users?! comment:27Changed 5 jaar ago by stefansat sat Oplossing: → invalid Status: reopened → closed Indeed if clientmaxidle = 0 it's not needed to change the default umaxidle = -1
  3. Ik heb ook VTI draaien, in welk afsluit menu bedoel je? Stond dat ergens in een config of was het de image van PLI?
  4. @Mimisiku Ik heb zoals je zei de CCcam protocol eruit gehaald en gebruik nu cs357x als protocol en ik heb in ieder geval gelijk al beeld. Morgenvroeg zal ik even checken bij de clientbox als er nog steeds connectie is via dit protocol. Ik laat het wel even weten, in ieder geval bedankt voor de tip! mvg, Wim
  5. Heb daar niet heel veel ervaring mee, heb het altijd op deze manier gedaan. Heb jij voor mij toevallig een voorbeeld van de instellingen die ik kan gebruiken?
  6. @Mimisiku Ik kan de rest van de regel jammer genoeg niet meer laten zien, die is al verderop in de logfile en heb geen idee hoe ik de voorgaande regels in de log tevoorschijn haal. Ik heb de logs niet opgeslagen namelijk. Had ook geen idee dat het mogelijk was met een Raspberry Pi een server te draaien, klinkt goed.
  7. Dit is mijn oscam config # oscam.conf generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11377 # Read more: http://www.streamboard.tv/svn/oscam/trunk/Distribution/doc/txt/oscam.conf.txt [global] disablelog = 1 logfile = /tmp/oscam.log pidfile = /tmp/oscam.pid unlockparental = 1 nice = -10 maxlogsize = 100 waitforcards = 0 preferlocalcards = 2 usrfile = /tmp/user.log cwlogdir = /var/log/ emmlogdir = /var/log/ [cache] [cccam] port = 14500 serverip = 192.168.178.52 nodeid = 4BB9686B104B1466 version = 2.0.11 [dvbapi] enabled = 1 au = 1 pmt_mode = 0 user = dvbapi_local boxtype = dreambox [webif] httpport = 83 httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255,10.0.0.0-10.255.0.255,255.255.255.255 httposcamlabel = Oscam WebInterface Dit is mijn oscam server # oscam.server generated automatically by Streamboard OSCAM 1.20-unstable_svn SVN r11377 # Read more: http://www.streamboard.tv/svn/oscam/trunk/Distribution/doc/txt/oscam.server.txt [reader] label = Ziggo_1 protocol = internal device = /dev/sci0 autospeed = 0 fallback = 1 caid = 0606 boxkey = 1122334455667788 rsakey = detect = cd mhz = 450 cardmhz = 2700 ident = 0606:000000,000001,000002,000003,0C5217 group = 1 emmcache = 1,1,15,0 auprovid = 0C5217 [reader] label = Ziggo_2 protocol = internal device = /dev/sci1 autospeed = 0 caid = 0606 boxkey = rsakey = detect = cd mhz = 450 cardmhz = 2700 ident = 0606:000000,000001,000002,000003,0C5217 group = 1 emmcache = 1,1,15,0 auprovid = 0C5217
  8. Ik heb even een regel uit de logfile van de serverbox gekopieerd, dit staat er wanneer de serverbox in standby staat. De ultimo4K is in dit geval de client. (ecm) ultimo4K (0606@000000/0000/4AED/4A:99535B4E3DAC4BD8A38664571A881292): rejected (166 ms) by Ziggo_1 (Invalid ecm type for cardfir
  9. Dank je wel voor jullie reacties. @mimisiku, ik vermoedt dat het de oscam is die mede in standby komt te staan. Ik heb hier met de kaart van Canal Digitaal nooit last van gehad net als de Ziggo 0604 kaart, dit werkte altijd. Ik heb nu de Ziggo0606 kaart en sindsdien heb ik daar last van. @bellejt, ik zal het eens proberen met fallback tuner. Heb deze optie nooit eerder hoeven te gebruiken maar zal eens checken als dat werkt. De kaart werkt overigens goed, krijgt ook alle updates binnen. Wanneer ik de serverbox aanzet heb ik op de client gelijk beeld, als ik naar bed ga en probeer de volgende morgen de client dan werkt het niet meer. Ik laat wel even weten als het gelukt is of niet. Mvg, Wim
  10. Goedemiddag, ik heb oscam draaien op 2 vu ontvangers, dit werkt op zich heel goed er is alleen een probleem. Wanneer de ontvanger (server) in standby word gezet kan ik op de client niet meer kijken, pas wanneer ik de ontvanger (server) weer aan zet komt het beeld weer terug. ik heb “keep alive” aangevinkt staan in oscam maar op een of andere manier werkt dat niet. Is er een mogelijkheid die er voor zorgt dat de connectie tussen beide boxen gehandhaaft blijft wanneer de server in standby staat? (Geen deep standby) ik hoop dat iemand mij kan helpen. vriendelijke groet, Wim
×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Onze Gebruiksvoorwaarden en Privacybeleid