Jump to content
Sign in to follow this  
Guest apo

Compoort linux cs server

Recommended Posts

Guest

hoi,

ik heb een vraagje aan jullie !

 

ik krijg een foutmelding bij het op starten van cs_srv

 

hij probeert de poorten te lezen en dan geeft ie aan

permission denied !

 

ik draai fedora 2

en laatste cs_srv vn ronald

 

kan iemand mij vertellen hoe ik deze probleem oplos

ik hem het geprobeert als super user en gewoon

allebei niet gelukt !

 

b.v.d.

 

apo <img src="/ubbthreads/images/graemlins/confused.gif" alt="" />

Share this post


Link to post
Share on other sites

Ben zelf niet bekend met de cs_srv, maar als hij bv naar /dev/ttyS0 probeert te schrijven, kun je hem permissie geven met:

 

chmod g+w /dev/ttyS0

 

Als dit niet werkt kun je evt. ook kijken naar de foutmelding die voorbijkomt met 'tail -f /var/log/messages' als je cs_srv opstart.

Share this post


Link to post
Share on other sites

met fedora draaid het niet goed als je op de dreambox forum had gezocht naar [ intel linuxcs_srv ]

dan zie je ook dat het aleen met de suse 8.1 werkt

en als je de file wat je in u /var/etc moet plaatsen= romu.cfg moet je de # = comando regel voor de poort aanduiding weg halen en de poort aangeven welke je wil gebruiken

com poort 1 = /dev/ttys0

en com poort 2 = /dev/ttys1 DACHT IK <img src="/ubbthreads/images/graemlins/laugh.gif" alt="" />

de groetjes djin

Share this post


Link to post
Share on other sites

met fedora werkt het prima hoor <img src="/ubbthreads/images/graemlins/xyxthumbs.gif" alt="" />

heb je wel het bestandje cs_srv en romu.config in een map staan .....als je teminste de laatste versie gebruikt

die ronald uit gebracht heeft

aleen suse9.0 geeft problemen

heb nu zelf linux xandros 2.0 en dat werkt ook prima

probeer eens in plaats van ttyS0....ttyS1

 

 

[server]

port = 1500

mode = 4

 

# Voorbeeld voor gebruik op intel linux PC.

# Er kunnen 3 phoenix programmers gebruikt worden, de parity moet ingesteld

# worden en kan zijn: E(ven) N(one) (O)odd, baudrate kan nog niet

# ingesteld worden omdat vooor alle supported kaarten dat 9600 is.

# Seca, parity = E, programmer op 3.5 MHz

# Irdeto, parity = N, programmer op 6.0 MHz

# De configuratie file romu.cfg moet nu niet meer staan in /var/etc (Wel op dreambox)

# maar in de directory waarin de server wordt opgestart. Op deze manier

# kunnen er meerdere servers draaien op veschillende porten.

# Uiteraard mogen 2 servers niet het zelfde phoenix device gebruiken. (werkt wel)

 

# Irdeto/beta

#phoenix_device_0 = /dev/ttyS1

#phoenix_parity_0 = N

 

# Seca

phoenix_device_1 = /dev/ttyS0

phoenix_parity_1 = E

 

Share this post


Link to post
Share on other sites
Guest

Het lijkt erop dat je dus geen rechten hebt om de poort te gebruiken..

 

En het rechten zetten kan dan ook alleen als je de recchten al hebt.

 

Ze zal het dus als root moeten draaien, of iig de rechten als root moeten zetten.

 

Jelle

Share this post


Link to post
Share on other sites
Guest
Citaat:
Het lijkt erop dat je dus geen rechten hebt om de poort te gebruiken..

En het rechten zetten kan dan ook alleen als je de recchten al hebt.

Ze zal het dus als root moeten draaien, of iig de rechten als root moeten zetten.

Jelle


hoe zet ik de rechten dan voor de poorten ?

Share this post


Link to post
Share on other sites
Guest

ik heb het geprobeerd met chmod g+w /dev/ttyS0

en ttyS1

 

maar ik krijg weer de permission denied te zien

 

de programma start wel gewoon op !

tijdens het lezen van de van de poorten geeft hij aan permission denied

 

kan het zijn dat het een andere poort is dan wat ik hierboven aan geef ?

 

of zal het te maken hebben met de firewall die ik draai ?

 

wie helpt ?

Share this post


Link to post
Share on other sites
Guest
Citaat:
ik heb het geprobeerd met chmod g+w /dev/ttyS0
en ttyS1

maar ik krijg weer de permission denied te zien

de programma start wel gewoon op !
tijdens het lezen van de van de poorten geeft hij aan permission denied

kan het zijn dat het een andere poort is dan wat ik hierboven aan geef ?

of zal het te maken hebben met de firewall die ik draai ?

wie helpt ?



oke heren iedereen bedankt ik heb het werkend gekregen !

groetjes,

apo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Onze Terms of Use en Privacy Policy