Jump to content
Sign in to follow this  
Satori

opzetten ftp servertje lukt niet

Recommended Posts

Beste medesatters,

 

Misschien kan een van jullie me helpen met het volgende probleem.

 

Ik wil een ftp-servertjes opzetten om af en toe grote files beschikbaar te stellen.

Het probleem is dat ik er van buiten niet bijkom.

 

Opzet:

Server-PC met vast IP-adres (192.168.0.200)

- WinXP, 3 GHz, 512 Mb intern, 2x200Gb Disk

- BulltitProof FTP servertje

- Getweakt speedtoch home modem

- ADSL met server-permissie, nat def voor poort 20 en 21 doorgezet van extern IP=0 -> 192.168.0.200.

 

Als ik intern ftp naar 192.168.0.200 werkt alles perfect.

In de log van de FTP-server zie ik:

 

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > connected to ip : 192.168.0.200

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > sending welcome message.

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > 220 ftp.NikkelWare.com

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > USER Wim

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > 331 Password required for Wim.

(000015) 5/30/2004 23:18:34 - (not logged in) (192.168.0.154) > PASS ********

(000015) 5/30/2004 23:18:34 - Wim (192.168.0.154) > logged in.

(000015) 5/30/2004 23:18:34 - Wim (192.168.0.154) > 230 User Wim logged in.

Enz.

 

Als ik van buiten inlog zie ik:

 

(000017) 5/30/2004 23:19:41 - (not logged in) (192.168.0.154) > connected to ip : 0.0.0.0

(000017) 5/30/2004 23:19:41 - (not logged in) (192.168.0.154) > sending welcome message.

(000017) 5/30/2004 23:19:41 - (not logged in) (192.168.0.154) > 220 ftp.NikkelWare.com

(000017) 5/30/2004 23:19:41 - (not logged in) (192.168.0.154) > disconnected.

 

Wat me opvalt is dat bij de laatste sessie de connected to ip: 0.0.0.0 is. Blijkbaar wordt mijn ip adres niet goed doorgegeven.

 

Als ik naar de instantiation in mijn ADSL modem kijk zie ik:

 

inside-adress:port=192.168.0.200:21

outside-address:port=123.456.789.012 (Ik heb hier nu een fake adres ingevuld, maar hier staat mijn ISP adres).

Foreign-address:port=0.0.0.0:0

 

Wat opvalt is dat het foreign adres niet ingevuld wordt, terwijl dat bij de andere instantiations (bijv poort 80) wel het geval is.

 

Uiteraard heb ik firewall en popup-killer tijdens het testen voor de zekerheid uit gezet.

 

Alvast bedankt,

Satori

Share this post


Link to post
Share on other sites

Mischien dat je hier iets aan hebt? dit en anders ff googlen levert wel mooie info op.

 

heb je wel TCP ipv UDP ports gemapped?

Share this post


Link to post
Share on other sites

JaNuZz, Bedankt voor het meedenken.

 

Voor de volledigheid: Ik ben hier al een paar weken mee bezig en ben begonnen met inlezen. Omdat ik nogal eens op reis ben is lezen het enige dat je ter voorbereiding kunt doen.

De "weethet" site is een bekende en google en ik hebben een dikke relatie.

Helaas heb ik met mijn googlelen niets kunnen vinden dat wat toevoegt. Daarom heb ik nu stiekem hoop op een medesatter die hier ook tegenaan gelopen is.

 

Je hulp wordt zeer op prjs gesteld.

 

Groeten

Satori

Share this post


Link to post
Share on other sites

Als je incidenteel je ftp aan gooit kan je beter je eigen ip adres hard invoeren.

 

Bulletproof opstarten - ftp server setup (of boven in de balk setup, main, general) - listen on port number 21 (het kan zijn dat je provider poort 21 blocked kies daarom voor een minder logische poort b.v. 4089) en vul daar de poort in waarop je connectie maakt.

 

(je adres wordt dan b.v. 217.143.125.48:4089)

 

Bulletproof opstarten - ftp server setup (of boven in de balk setup, main, multi IP settings) - multi IP settings - Alleen aanvinken passive mode IP en daar je ip adres hard invoeren.

 

Bij passive poort range vul je in jou geval 20 to 21 (in mijn geval heb ik hem een range van 30 poorten gegeven en die ook zo ingevuld bij mijn NAT in mijn router).

 

Je moet er wel om denken dat elke keer als je een nieuw IP krijgt je die ook hier moet veranderen.

Share this post


Link to post
Share on other sites

Morgothzz,

 

Bedankt voor je reactie.

 

Het interne IP adres en passieve mode had ik inderdaad al ingevuld. (Via Google gevonden).

 

Ik heb contact met mijn provider gezocht en volgens hen staan de poorten 20 en 21 gewoon open en wordt dat niet tegengehouden.

 

Ik heb gexperimenteerd met andere poorten, zoals je voorstelde, maar dat levert exact hetzelfde op. Dus open gezet in Bullit en ook gecreeerd in mijn Alcatel modem. Hieronder de log voor poort 4444:

 

5/31/2004 20:13:58 - FTP Server On-line : IP(s) 192.168.0.200, on port 4444

(000012) 5/31/2004 20:14:01 - (not logged in) (192.168.0.154) > connected to ip : 0.0.0.0

(000012) 5/31/2004 20:14:01 - (not logged in) (192.168.0.154) > sending welcome message.

(000012) 5/31/2004 20:14:01 - (not logged in) (192.168.0.154) > 220 ftp.NikkelWare.com

(000012) 5/31/2004 20:14:01 - (not logged in) (192.168.0.154) > disconnected.

(000013) 5/31/2004 20:14:04 - (not logged in) (192.168.0.154) > connected to ip : 0.0.0.0

(000013) 5/31/2004 20:14:04 - (not logged in) (192.168.0.154) > sending welcome message.

(000013) 5/31/2004 20:14:04 - (not logged in) (192.168.0.154) > 220 ftp.NikkelWare.com

(000013) 5/31/2004 20:14:04 - (not logged in) (192.168.0.154) > disconnected.

 

In de log kun je zien dat de server op 192.168.0.200 loopt (dit is een vast IP-adres) en dat ik via 192.168.0.154 de server probeer te benaderen alleen wordt de "Connected to" niet opgelost.

 

Ik krijg om die reden de indruk dat er iets niet goed zit in mijn Alcatel modem. Het foreign address wordt nl niet ingevuld.

 

Als iemand zich uitgedaagd voelt, houd ik me aanbevolen.

 

Groeten

Satori

Share this post


Link to post
Share on other sites

Als je nou eens ff snel een webservertje op die pc opengooit en poort 80 forward in je router op dezelfde manier , kan je daar vanaf buiten wel op komen dan?

Share this post


Link to post
Share on other sites

Beste MedeSatters,

 

Het probleem is opgelost. Er was nl. geen probleem!!

 

Wat wil het geval: Ik heb zitten testen met een andere pc in mijn thuisnetwerk en dat lukte niet.

Op de ADSL-online site was iemand met hetzelfde probleem en daar bleek dat mensen buiten zijn thuisnetwerk wel via het ISP-IP_adres op zijn server konden komen, maar zijn eigen pc's niet. Ik heb daarom samen met een neefje met ADSL een test gedaan en hij kan gewoon FTPen.

 

Samengevat:

Van buiten kun je FTPen op je ISP-IP_Adres, maar vanuit je eigen netwerk niet.

 

Het foreign-address werd nu ook netjes ingevuld in het Alcatel modem.

 

Allemaal bedankt voor het meedenken. Ik had al opgegeven, maar door de discussies hier ben ik weer opnieuw met zoeken begonnen met positief resultaat.

 

Groeten

Satori

Share this post


Link to post
Share on other sites

He he klopt, was ik helemaal vergeten te vertellen. Ik had ook om die reden (en uit gemak) een dynip adres opgezet. Op die manier kan je wel je interne server bereiken en hem testen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Onze Terms of Use en Privacy Policy