Ga naar inhoud
Log in om dit te volgen  
MSneijders

[DM500] Restore van Backup

Aanbevolen berichten

gisteren kwam ik na een foutje op het punt waar ik wilde restoren van een eerder gemaakte backup. De backup was gemaakt vanuit het PLI menu.

Maar na te selecteren wat ik wilde restoren, kreeg ik de foutmelding

"no device selected"

 

Wat betekend deze kreet?

Hoe moet ik een device selecteren

Heeft iemand deze functionaliteit al getest? (op een dm500)

 

Het betref hier een dm500s met Pli flubber-the sequel met een up-to date menu en een harddisk van een pc gemount onder /hdd

 

Matthijs

Deel dit bericht


Link naar bericht
Delen op andere sites

Gast

Aangezien ik het script zelf gemaakt heb....

 

Die melding van no device selected geeft aan dat er geen apparaat meegestuurd is tijdens het uitvoeren van het script.

 

De opdracht regel bestaat uit script...opdracht...apparaat

de opdrachten die mogelijk zijn :

backup" "settings" "addons" "config" "enigma" "cams" "samba" "bin" "etc" "lib" "spool" "share" "keys"

 

De apparaten die mogelijk zijn : "HDD" "USB"

 

Dus de opdrachtregel wordt voor een usb stickie :

/var/bin/backup.sh keys USB

 

 

Dus je melding is of een fout in de tools.xml bestand of het script zelf bevat een fout..

Het laatste lijkt me onwaarschijnlijk omdat het script voor bijna iedere DB gelijk is. de bestandslocaties varieren iets.

 

Je zou bovenstaande opdracht ook eens via telnet uit kunnen voeren om te kijken waar het goed of fout gaat.

 

Je bevindingen graag PM of hier posten...

Deel dit bericht


Link naar bericht
Delen op andere sites

@SCDGRO

het script in /var/bin mankeerde niets aan!

vanuit telnet gerunned, ging goed. (DM500 heeft trouwens geen USB)

 

Na verdere inspectie van tools.xml bleek dat precies het restoren van de keys inplaats van met HDD gevuld was met keys:

<Execute name="Restore Keys:" target="/var/bin/backup.sh keys keys" confirmation......../>

in plaats van

<Execute name="Restore Keys:" target="/var/bin/backup.sh keys HDD" confirmation......../>

 

Kan dit worden opgelost in de menu updater??

 

Matthijs

Deel dit bericht


Link naar bericht
Delen op andere sites
Citaat:
@SCDGRO
het script in /var/bin mankeerde niets aan!
vanuit telnet gerunned, ging goed. (DM500 heeft trouwens geen USB)

Na verdere inspectie van tools.xml bleek dat precies het restoren van de keys inplaats van met HDD gevuld was met keys:
<Execute name="Restore Keys:" target="/var/bin/backup.sh keys keys" confirmation......../>
in plaats van
<Execute name="Restore Keys:" target="/var/bin/backup.sh keys HDD" confirmation......../>

Kan dit worden opgelost in de menu updater??

Matthijs

Als scdgro de fout ziet, is 't simpel op te lossen door het laatste tools menu te downloaden. Ik zal met hem effe overleggen.

Deel dit bericht


Link naar bericht
Delen op andere sites

Maak een account aan of log in om te reageren

Je moet een lid zijn om een reactie te kunnen achterlaten

Account aanmaken

Registreer voor een nieuwe account in onze community. Het is erg gemakkelijk!

Registreer een nieuwe account

Inloggen

Heb je reeds een account? Log hier in.

Nu inloggen
Log in om dit te volgen  

  • Wie is er online   0 leden

    Er zijn geen geregistreerde gebruikers deze pagina aan het bekijken

×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.