Jump to content


volgorde bepalen laden modules dbv-kaarten fysiek en virtueel


Guest wiggerd

Recommended Posts

Guest wiggerd

Hoi,

 

Na een hoop gezoek en gepiel en gek^*&^ heb ik mijn systeem bijna volledig draaiende.

 

Ik zit echter met het volgende probleem. het lijkt wel alsof bij de ene boot de echte (satelco) driver wordt geladen, en later de dvbloopback, en de andere keer juist andersom. met als gevolg dat ik bij sasc foutmelding krijg als ik de fysieke met de virtuele wil koppelen. (0:1) dan is nl eerst de virtuele module geladen. dus draai ik het om (1:0) en het werkt. (en bij mythbackend moet ik het dus ook veranderen...)

(re)boot ik weer, dan is weer de ander eerst geladen...

 

Dus, hoe regel ik de module-laad volgorde?

dvbloop wordt geladen middels /etc/modules/

 

plz helppp

 

p.s. mythbuntu 9.10 met newcs 1.67cr en sasc-ng werkend!

Link to comment
Share on other sites


Guest wiggerd

dank voor de snelle reacties!

 

@zit zeker wat in, dan wordt de juiste module altijd als eerste geladen.

@rigolo, voor ik je tip verder ga onderzoeken, zit ik dan niet nog steeds met het probleem dat mythbackend afwisselend naar /dev/dvb0 / /dev/dvb1 moet kijken?

 

Groet, Floris

p.s. ik heb een redelijke howto voor mijn situatie geschreven. misschien hebben anderen er ook wat aan als het helemaal goed functioneert. ideetje? bij mythtv.nl ofzo?

Link to comment
Share on other sites

Ik heb diverse DVB-T kaarten in m'n OpenSUSE systeem en liep ook tegen het probleem aan dat sasc eerder werd geladen dan de drivers. Mijn oplossing is sasc gewoon later laden. Ook mythbackend laat ik weer later opstarten. Mijn primitief script:

 

#!/bin/sh

sleep 5

/usr/local/bin/newcs &

sleep 5

modprobe dvbloopback num_adapters=4

sleep 2

LD_LIBRARY_PATH=/usr/src/vdr-sc/sasc/contrib/sasc-ng/sc/PLUGINS/lib

/usr/src/vdr-sc/sasc/contrib/sasc-ng/sasc-ng -j 0:4 -j 1:5 -j 2:6 -j 3:7 -D --cam-budget --daemon --buffer 4M --cam-dir /usr/local/etc/opensasc --log /var/log/mythtv/sasc-ng &

sleep 5

/etc/init.d/mythbackend start

 

Op deze manier krijgt het systeem de tijd om de drivers te laden en daarna de rest. Ook opletten dat je systeem het netwerk in de lucht heeft anders krijg je een foutmelding van sasc dat hij geen contact kan maken met newcs. Als je mythbackend meteen laat starten na sasc zijn je virtuele devices nog niet aangemaakt dus vandaar dat ik hem daar ook even laat wachten.

Misschien kun je er wat mee.

Link to comment
Share on other sites

Guest wiggerd

ik heb via /etc/modules het goed. echter start myhthbackend blijkbaar te vroeg op. ik krijg een foutmelding in de frontend. ik heb de backend als laatste script laten starten:

sudo update-rc.d -f mythtv-backend remove

sudo update-rc.d mythtv-backend defaults 99

maar na een reboot dezelfde foutmelding over de tunercard.

toen heb ik de startscripts eruit gehaald:

sudo update-rc.d mythtv-backend defaults 99

maar na een reboot blijkt dat de backend wel wordt opgestart: myhthfrontend geeft geen melding dat hij de backend niet kan vinden.

als ik de backend kill, en daarna opstart dat gaat het goed. dus de dvbloop, newcs en sasc-ng starten in de juiste volgorde.

heeeeeel raar allemaal....

 

@FreddyX,

je start en stopt newcs dus niet met een init-script? en wanneer start je script? enne: wat een luxe, 4 tv-kaarten!!!!

 

grzzz Floris

Link to comment
Share on other sites

Nee, ik start newcs niet via een init script. Ik heb dit bewust zo gedaan zodat ik meer controle heb over wanneer het gestart wordt. En het werkt zo prima, geen problemen dat of het één of het ander te vroeg of te laat gestart wordt. Je zou het eens kunnen proberen op deze manier. Misschien zijn de wait tijden op jouw systeem wat anders maar dat is een kwestie van proberen.

 

Op mijn openSUSE 11.2 systeem heb ik deze regel toegevoegd aan /etc/init.d/halt.local

 

chkconfig --set mythbackend off &

 

Dit deactiveert mythbackend tijdens het afsluiten van het systeem zodat deze bij de volgende herstart niet uitgevoerd wordt. (Tijdens een update wordt mythbackend weer ingeschakeld)

Volgens mij is het op je ubuntu systeem:

 

update-rc.d -f mythtv-backend remove

 

En tijdens het afsluiten van het systeem wordt newcs vanzelf wel afgesloten, heb je geen script voor nodig.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Lees alvorens je verder gaat onze Terms of Use en Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.