Jump to content
Sign in to follow this  
-= [ Appien ] =-

VPN pptpd PoPToP en de MTU size

Recommended Posts

Ik heb een probleempje met mijn vpn bak (pptpd PoPToP v 1.1.3 & 1.1.4 op Redhat 8.0/9.0)

 

Zo gauw als ik met mijn client op de vpn inlog kan ik (bijna) niets meer toen, pingen en surfen naar kleine site's (klein = 1 regel tekst) gaat goed, maar zo gauw de pakketjes groter worden is het over met de pret.

 

Als ik de mtu size van de ppp0 interface op 1500 zet werkt het wel uitstekend

 

(ifconfig ppp0 mtu 1500) (normaal staat hij op 1396)

 

Ik heb een optie gevonden om te mtu size standaard aan te passen, deze moest dan in de /etc/ppp/options.pptpd gezet worden

 

mtu 1500

 

maar wat ik ook verander, de ppp interface blijft hardnekkig op 1396 staan.

 

Hoe valt dit op te lossen? Ik zat eerst te denken om in de /etc/ppp/ip-up.local een scriptje te zetten wat na het connecten de mtu size aanpast, maar dit lijkt mij niet DE oplossing....

Share this post


Link to post
Share on other sites

Guest

Even kijken of ik je begrijp:

[Webserver]--[netwerk]--[VPN termination point]--[internet]--[RH 8 PPTP server]--[Client OS unkown?]

 

Is dit wat je bedoeld?

 

Opzicht zou je MTU en MRU in /etc/ppp/options.pptpd moeten werken. Maar ik zie geen bezwaar om het in het ip-up script te zetten.

 

Overigens zou ikzelf voor FreeSwan/IPSec gekozen hebben (sterk nog; dat heb ik al gedaan <img src="/ubbthreads/images/graemlins/grin.gif" alt="" />) maar je hebt vast met een reden deze keuze gemaakt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Onze Terms of Use en Privacy Policy