Ga naar inhoud

mounthulp


micronikje
 Delen

Aanbevolen berichten

Ik snap het niet meer. Ik heb de volgende stappen ondernomen, om mijn pc te kunnen gebruiken voor het opnemen van films:

1. truegrid nfsserver op pc gezet.

2. de mappen c:\dreambox en en c:\dreambox\movie gemaakt.

3. de map etc in de windowsmap gemaakt.

4. de bestanden rpc en exports hierheen verplaatst.

5. /dreambox -path=c:\dreambox in het bestand exports gezet.

6. de commando's portmap add, nfs add en nfs start gedaan.

7. telnetsessie gestart en het commando mount -t nfs -o nolock 192.168.0.1:/dreambox /hdd gegeven.

Het zou nu moeten werken, maar in de db zie ik alleen de ingebouwde harddisk, met een fout aantal gb's nu. reboot ik de db dan zie ik de harddisk met de juiste aantallen gb's, maar nog steeds geen mount. Weet iemand hoe je dit oplost?

Dreambox 7000/Micronik 1200S/2 x DM800

Link naar bericht
Delen op andere sites


Je weet wel zeker dat het IP-adres dat je in je post hebt staan ook het IP-adres van je PC is? Tevens heb je een "normaal" filesysteem op je PC staan? Dus gewoon NTFS, FAT32 of FAT? EN geen Win2000 server met mirroring, mountpoints, ofzo. Want dat laatste heb ik geprobeert, maar niet aan de gang te krijgen.

Link naar bericht
Delen op andere sites

Volgens mij stond er ook nog ergens in de helpfile van die nfs software dat je in de hostfile van de PC de IP-addressen een naam moest geven.

 

HOSTS FILE AND DNS

-----------------------

You must have a HOSTS file on your PC, or else

you must have enabled remote DNS lookup. Otherwise

WinSock calls to convert names to IP addresses

will not function.

 

Tevens staat er bij mij op m'n dreambox het volgende:

mount -t nfs -o nolock "192.168.0.1":/dreambox /hdd Dus er staan dubbelle "" om het IP-adres.

Link naar bericht
Delen op andere sites

Nu snap ik er helemaal niks meer van! Ik heb de hosts file aangepast met het ip adres van de pc en dreambox als omschrijving. pc opnieuw opgestart. telnetsessie met de mount gedaan nu met "". Zie ik in mijn menu van de db bij harddisk weer het foute aantal gb's staan. even een stukje film opgenomen. staat er op de harddisk van de pc de 2 bestanden .ts en .epl van 1 kb groot. Deze 2 bestanden met dezelfde grootte staan ook op de harddisk van de db en als ik kijk in de hdd/movie map via ftp zie ik de 2 bestanden staan met als grootte 188 kb (ts) en 406 kb (epl).

Wie kan er nu nog een touw aan vastknopen???

Dreambox 7000/Micronik 1200S/2 x DM800

Link naar bericht
Delen op andere sites

Probeer de mount eens op deze manier (mount -t nfs -o nolock 192.168.0.1:/dreambox /mnt), en dan kijk je in de map mnt op je dreambox of hij daar in staat;

Ik denk omdat je er een interne hdd in hebt, je mount dubbel de hdd dir moet gebruiken, en dat gaat niet.

 

 

greets Rongogo

 

 

Link naar bericht
Delen op andere sites

verwijder van je dreambox harddisk de /hdd/movie directory (beter nog : rename die.. mv /hdd/movie /hdd/movie_old)

 

mount nu de PC harddisk direct op de directory /hdd/movie

(jouw stap 7 :: mount -t nfs -o nolock 192.168.0.1:/dreambox /hdd/movie)

 

 

telnet nu naar de dreambox.. en creeer op de /hdd/movie (wat de NFS mount moet voorstellen) een file.. (voorbeeld : cp /bin/enigma /hdd/movie

 

check op je pc of die file daar staat ... of via je dreambox (ls -ltra /hdd/movie)

 

als het tot zo ver werkt dan is alles in orde.. zo niet klopt je settings niet..

The Source is Out There....

Link naar bericht
Delen op andere sites

@Romeo_

als ik de harddisk op mijn dreambox verander in movie_old, dan gebeurt dit ook bij hdd. Als ik dan stap 7 doe krijg ik de foutmelding: no such file or directory, terwijl de map c:\dreambox\movie wel bestaat. Wat doe ik fout in de settings?

Dreambox 7000/Micronik 1200S/2 x DM800

Link naar bericht
Delen op andere sites

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.
Opgelet: Je bericht zal moeten worden goedgekeurd door een moderator alvorens het zichtbaar zal worden.

Gast
Reageer op dit topic

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

 Delen

  • Wie is er online   0 leden

    • Er zijn geen geregistreerde gebruikers deze pagina aan het bekijken
×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.