Ga naar inhoud
Log in om dit te volgen  
orbiter

[DBOX-II] netpilot probleem met ruNE.DBOX2/ruDbox/20040118

Aanbevolen berichten

Als ik op het image ruNEDBOX2 (Enigma) radegast via het menu in DBox instel op:

Local port - 666

Shared port - 678

 

Als ik dan een port-scan uitvoer op deze DBox dan is poort 666 wel open en poort 678 niet ?

Ik neem aan dat het probleem hier ligt dat netpilot niet opstart.

Netpilot kan ik niet handmatig opstarten in een telnet-seesie, radegast weer wel. radegast en netpilot staan in:

var/etc/netpilot

var/etc/radegast.cfg

var/tmp/netpilot

var/emu/rdgd

 

Hoe krijg ik het voormekaar zodat ik netpilot wel krijg gestart, of zelfs automatisch start...

 

[color:"red"] Hier een kopie van mijn telnet-sessie:

 

# rdgd

radegast deamon (project Radegast), version 2.2final/SLIM/dbox2

© 2k3, kindzadza and the rest of Radegast team (compiled for dbox2 by mixvt)

This proggie is beerware. If you find it usefull

don't forget to host our team <img src="/ubbthreads/images/graemlins/wink.gif" alt="" />

This code is for educational purpose only.

 

cfg : Loading config file /var/etc/radegast.cfg

cr : Error opening device '/dev/sci1'

cr : Error opening device '/dev/sci0'

#

# LocCMD : Is starting.

LocCMD : Waiting for connection on /var/tmp/rdgd.cmd

NetCMD : Is starting.

NetCMD : socket bind error (errno=98)

 

#

# netpilot

-sh: netpilot: not found

#

[/color]

Deel dit bericht


Link naar bericht
Delen op andere sites

Dit zelfde probleem heb ik dus ook!!

 

Ik krijg die netpilot ook maar niet aan de gang.

 

Als iemand een antwoord weet graag <img src="/ubbthreads/images/graemlins/biggthumpup.gif" alt="" />

Deel dit bericht


Link naar bericht
Delen op andere sites
Gast

Ik ben hier net samen met Orbiter mee bezig geweest.

Wat bleek:

De permissies van netpilot stonden niet goed. De flag +X was niet aanwezig, dus was het niet uitvoerbaar.

Nadat we dit met chmod gecorrigeerd hadden, refereerde het systeem naar /bin/netpilot terwijl het bestand daar niet stond. Nadat het bestand naar /bin gecopieerd werd, waren er geen foutmeldingen meer.

Echter werkte het nog niet omdat "rdgd" de volgende melding genereerde:

 

cr : Error opening device '/dev/sci1'

cr : Error opening device '/dev/sci0'

 

Op zich logisch, want /dev/sci0 en 1 bestonden niet.

Aangezien ikzelf voornamelijk bekend ben met de dreambox, weet ik niet wat op de DBOX2 het /dev bestand is wat naar de cardreaders verwijst en heb wel geprobeerd een symlink te leggen van /dev/cua/0 en /dev/cua/1 naar respectievelijk /dev/sci0 en /dev/sci1, maar dit mocht niet baten.

Mocht iemand weten wat dit wél moet zijn, post het hier zodat dit mysterie te onrafelen is.

 

Bij voorbaat dank.

Deel dit bericht


Link naar bericht
Delen op andere sites

Maak een account aan of log in om te reageren

Je moet een lid zijn om een reactie te kunnen achterlaten

Account aanmaken

Registreer voor een nieuwe account in onze community. Het is erg gemakkelijk!

Registreer een nieuwe account

Inloggen

Heb je reeds een account? Log hier in.

Nu inloggen
Log in om dit te volgen  

  • Wie is er online   0 leden

    Er zijn geen geregistreerde gebruikers deze pagina aan het bekijken

×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.