Jump to content


Repeating timer bug werkomheen'tje


tCC

Recommended Posts

aangezien de timerbug nog steeds niet gefixed is (zie http://www.sat4all.com/ubbthreads/showflat.php?Cat=0&Board=dreambox&Number=697645 ) heb ik een scriptje gemaakt (inderdaad, mijn weekend was echt saai) die gewoon de corrupte lines eruit haalt.

 

misschien een idee voor Pent om zo iets mee te nemen in een eventuele nieuwe MV release nadat men een timer entry geadd heeft via MV. tot die tijd heb ik iig weer wat te cron'en <img src="/ubbthreads/images/graemlins/wink.gif" alt="" />

 

dit komt trouwens vaak/alleen voor bij repeating timers (tijdje lopen testen, vooral vandaag ging het nogal vaak mis), maar ach, dit script werkt altijd goed, gelukte en mislukte opnames komen toch in de timerlist als TYPE 2572 (rood kruisie) en TYPE 268 (groen vinkie). zo te zien gebeurt er geen ruk met die #LAST_ACTIVATION entry.

 

=====================

 

#!/bin/sh

# gotimer 1.0 2004.10.31 by tCC

 

# Saving the current timer.epl in case we've modified something and the change isn't yet written to the timer.epl

wget -O /tmp/gotimer.temp -q http://127.0.0.1/cgi-bin/saveTimerList

 

# Removing corrupt entries from the timer.epl

cat /var/tuxbox/config/enigma/timer.epl | grep -v "#LAST_ACTIVATION" >/tmp/gotimer.temp

 

# Replacing existing timer with new timer

cp /tmp/gotimer.temp /var/tuxbox/config/enigma/timer.epl

 

# Reloading the timerlist in Enigma

wget -O /tmp/gotimer.temp -q http://127.0.0.1/cgi-bin/reloadTimerList

 

# Removing temporary files

rm /tmp/gotimer.*

domme vragen bestaan niet, domme mensen wel.
Link to comment
Share on other sites


het zou trouwens wel beter zijn als die op een of andere manier in MV verwerkt wordt (of nog beter, DMM gewoon die bug er uit halen), want als je een timer stopt (dus gewoon weg zappen terwijl ie aan het opnemen is en je de recording dus afbreekt) zal de opname weer beginnen te lopen als de timer ge-reload wordt, niet echt handig dus.

 

we zien het wel <img src="/ubbthreads/images/graemlins/smile.gif" alt="" />

 

alvast bedankt Pent :P *hint*

domme vragen bestaan niet, domme mensen wel.
Link to comment
Share on other sites

Oorspronkelijk had ik dir thread opgestart.

De manier die je toen omschreef werkte.

 

Sinds ik de 1.08 hydra's gebruik hab ik die problemen niet meer gehad??

 

Misschien toch dat het probleem is opgelost?

Wel te vermelden dat de timerlist nog steeds van image naar image wordt gecopieerd. Wel te verstaan de volgens jouw methode aangepaste versie!!

 

Thanks

 

Dagger38

VU+ duo 4K SE ontvanger

Link to comment
Share on other sites

ik kan niet zeggen wanneer het nou precies mis gaat, sommige werken wel goed en sommige niet, dat is juist het vreemde.

 

wel weet ik, dan als ik die last_activation's eruit knikker ze altijd WEL werken.

domme vragen bestaan niet, domme mensen wel.
Link to comment
Share on other sites

  • 1 month later...

@tCC

 

in PLi 2911 nu al weer enige weken betrouwbare opnames, dit script laten draaien midden in de nacht m.b.v. cron werkt perfect.

 

Bedankt <img src="/ubbthreads/images/graemlins/biggthumpup.gif" alt="" /> <img src="/ubbthreads/images/graemlins/biggthumpup.gif" alt="" /> <img src="/ubbthreads/images/graemlins/biggthumpup.gif" alt="" />

Link to comment
Share on other sites

Bezit Hydra Zeus eigenlijk wel de cron daemon? Ik kan hem in iedergeval even niet vinden op mijn DB.

 

Hoe kan ik cron toevoegen? Zit deze niet toevallig bij een van de addons?

 

Tengx

 

Urk.

3xDM800

1xVisiosat Bigsat met 2x Inverto quad lnb's en 2x Alps quad lnb's

1xEdubuntu server met 500GB voor o.a. de 3 DM's

Link to comment
Share on other sites

Citaat:
Bezit Hydra Zeus eigenlijk wel de cron daemon? Ik kan hem in iedergeval even niet vinden op mijn DB.

Hoe kan ik cron toevoegen? Zit deze niet toevallig bij een van de addons?

Tengx

Urk.

crond zit er gewoon in\

en gewoon starten tijdens booten met init script volgens mij met crond&
domme vragen bestaan niet, domme mensen wel.
Link to comment
Share on other sites

Ik zie hem echt niet staan. Als ik cron& type, dan geeft hij aan dat hij hem niet kan vinden. In alle init scripts zie ik ook niets staan mbt cron en ook niet in de proces listing.

 

Zou het ermee te maken kunnen hebben dat cron niet te vinden is omdat ik multiboot gebruik?

 

Tengx

 

Urk

3xDM800

1xVisiosat Bigsat met 2x Inverto quad lnb's en 2x Alps quad lnb's

1xEdubuntu server met 500GB voor o.a. de 3 DM's

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Lees alvorens je verder gaat onze Terms of Use en Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.