Jump to content


OSCam Reader auto-retry


xorinzor

Recommended Posts

Hoi!

Ik heb een probleempje met mijn OSCam, de reader init is niet bepaald consistent namelijk. In 90% van de gevallen moet ik zelf handmatig de reader een keertje resetten omdat deze niet goed geinitialiseerd is waarna deze gewoon wel werkt.

Nou kan ik via google niet echt iets vinden op diverse termen onder het mom van: "oscam reader auto-retry"  of iets dergelijks, en heb ik ook zelf in de documentatie niet echt een optie kunnen vinden die er voor mij uit sprong als: dat is m!

Dit is de foutmelding die er te staan komt op de momenten waarop het niet lukt: THIS WAS A FAILED START ATTEMPT No 1 out of max alloted of 1

Zijn er andere mensen met dit probleem? en zo ja, hoe hebben jullie het weten op te lossen?
Is dit iets wat zich automatisch probeert te herstellen als deze een request voor een channel krijgt? (ik zit nog te wachten op een verloopstukje voordat ik een daadwerkelijk TV signaal in mijn tvheadend via HDHomeRun zal kunnen voeren).

Alvast bedankt!

Edited by xorinzor
Link to comment
Share on other sites


@Sjaak(k)

oscam.server

Spoiler

[reader]
label                         = ziggo
description                   = Ziggo smartcard
protocol                      = smargo
detect                        = CD
device                        = /dev/ttyUSB0
smargopatch                   = 1
caid                          = 0604
boxkey                        = 1122334455667788
rsakey                        = 3C .. 6A
force_irdeto                  = 1
detect                        = cd
mhz                           = 600
cardmhz                       = 600
group                         = 1
emmcache                      = 1,3,2,0

 


Fail-Log

Spoiler

2018/01/26 17:20:40 45260620 r   (reader) ziggo [smargo] Buffers readed  0 bytes total time_us 75487
2018/01/26 17:20:40 45260620 r   (reader) ziggo [smargo] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz= AUTO, cardmhz=600)
2018/01/26 17:20:41 45260620 r   (reader) ziggo [smargo] card detected
2018/01/26 17:20:49 45260620 r   (reader) ziggo [smargo] ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 20 56 35 2E 37 9A
2018/01/26 17:20:49 45260620 r   (reader) ziggo [smargo] Init card protocol T14, FI=2, F=558, D=1, N=0
2018/01/26 17:20:49 45260620 r   (reader) ziggo [smargo] Calculated work ETU is 93.00 us reader mhz = 600
2018/01/26 17:20:49 45260620 r   (reader) ziggo [smargo] ATR Fsmax is 6 MHz, clocking card to wanted user cardclock of 6.00 MHz (specified in reader->mhz)
2018/01/26 17:20:50 45260620 r   (reader) ziggo [smargo] detect irdeto card
2018/01/26 17:20:50 45260620 r   (reader) ziggo [smargo] Irdeto SC 57 version 12 revision 1, patch level e
2018/01/26 17:20:51 45260620 r   (reader) ziggo [smargo] caid: 0604, acs: 6.08, country code: NLD
2018/01/26 17:20:51 45260620 r   (reader) ziggo [smargo] providers: 4, ascii serial: ##########, hex serial: ######, hex base: ##
2018/01/26 17:20:55 45260620 r   (reader) ziggo [smargo] card system not supported
2018/01/26 17:20:55 45260620 r   (reader) ziggo [smargo] Normal mode failed, reverting to Deprecated Mode
2018/01/26 17:21:03 45260620 r   (reader) ziggo [smargo] ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 20 56 35 2E 37 9A
2018/01/26 17:21:03 45260620 r   (reader) ziggo [smargo] Init card protocol T14, FI=2, F=558, D=1, N=0
2018/01/26 17:21:03 45260620 r   (reader) ziggo [smargo] Calculated work ETU is 69.66 us reader mhz = 534
2018/01/26 17:21:03 45260620 r   (reader) ziggo [smargo] ATR Fsmax is 5 MHz, clocking card to wanted user cardclock of 5.34 MHz (specified in reader->mhz)
2018/01/26 17:21:04 45260620 r   (reader) ziggo [smargo] detect irdeto card
2018/01/26 17:21:04 45260620 r   (reader) ziggo [smargo] Irdeto SC 57 version 12 revision 1, patch level e
2018/01/26 17:21:04 45260620 r   (reader) ziggo [smargo] caid: 0604, acs: 6.08, country code: NLD
2018/01/26 17:21:06 45260620 r   (reader) ziggo [smargo] providers: 4, ascii serial: ##########, hex serial: ######, hex base: ##
2018/01/26 17:21:09 45260620 r   (reader) ziggo [smargo] card system not supported
2018/01/26 17:21:09 45260620 r   (reader) ziggo [smargo] THIS WAS A FAILED START ATTEMPT No 1 out of max alloted of 1
2018/01/26 17:21:09 45260620 r   (reader) ziggo [smargo] card initializing error

 


Success-Log

Spoiler

2018/01/26 19:07:07 00ED9640 h    (webif) Reader ziggo restarted by WebIF from 192.168.178.125
2018/01/26 19:07:08 44F329E4 r   (reader) ziggo [smargo] creating thread for device /dev/ttyUSB0
2018/01/26 19:07:08 5655409D r   (reader) ziggo [smargo] Buffers readed  0 bytes total time_us 75496
2018/01/26 19:07:08 5655409D r   (reader) ziggo [smargo] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz= AUTO, cardmhz=600)
2018/01/26 19:07:09 5655409D r   (reader) ziggo [smargo] card detected
2018/01/26 19:07:17 5655409D r   (reader) ziggo [smargo] ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 20 56 35 2E 37 9A 
2018/01/26 19:07:17 5655409D r   (reader) ziggo [smargo] Init card protocol T14, FI=2, F=558, D=1, N=0
2018/01/26 19:07:17 5655409D r   (reader) ziggo [smargo] Calculated work ETU is 93.00 us reader mhz = 600
2018/01/26 19:07:17 5655409D r   (reader) ziggo [smargo] ATR Fsmax is 6 MHz, clocking card to wanted user cardclock of 6.00 MHz (specified in reader->mhz)
2018/01/26 19:07:18 5655409D r   (reader) ziggo [smargo] detect irdeto card
2018/01/26 19:07:18 5655409D r   (reader) ziggo [smargo] Irdeto SC 57 version 12 revision 1, patch level e
2018/01/26 19:07:18 5655409D r   (reader) ziggo [smargo] caid: 0604, acs: 6.08, country code: NLD
2018/01/26 19:07:18 5655409D r   (reader) ziggo [smargo] providers: 4, ascii serial: ##########, hex serial: ######, hex base: ##
2018/01/26 19:07:25 5655409D r   (reader) ziggo [smargo] active providers: 4 (0c0bb4,006900,006900,006900)
2018/01/26 19:07:25 5655409D r   (reader) ziggo [smargo] found card system irdeto
2018/01/26 19:07:25 5655409D r   (reader) ziggo [irdeto] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max alloted of 1

 


Wellicht handig om te vermelden dat ik de Smargo Smartreader v2 gebruik

Edited by xorinzor
Link to comment
Share on other sites

In je reader mis ik

 

nice=1

smargofix=1

 

Raspberry Pi 3B+ Argolis Triple Reader Kaartserver + Smargo

Vu+ Zero 4K DVB-S2X, Vu+ Zero 4K DVB-C/T2, DM525 Combo, DM920 UHD

VU+Ultimo4K BTE,  DM-One UHD, Ziggo, HD+, TV-Vlaanderen, ORF, TiVuSAT

13°E,19.2°E, 23.5°E, 28.2°E. Triax 88 en Triax 60

Link to comment
Share on other sites

@Sjaak(k)

 

Ik heb de opties toegevoegd, maar het lijkt niet te hebben geholpen, heb na het toepassen van de wijzigingen en het herstarten van de oscam service uiteindelijk 3x de reader opnieuw moeten initialiseren voordat deze gepakt werdt.

Heb op andere fora gelezen dat dit iets met een timeout te maken heeft van de reply die de reader krijgt van de smartcard oid? dat zou de smargopatch=1 moeten oplossen dacht ik, en hoewel dit inderdaad een verschil heeft gemaakt tussen compleet niet werken, en nu in sommige gevallen wel, blijft dit dus een zeer inconsistent probleem.

Wat ik echter raar vind is dat er dus blijkbaar geen enkele optie is om het systeem automatisch opnieuw de reader/kaart te laten initialiseren als er zich een fout voordoet?

EDIT: Ik heb inmiddels een bash scriptje geschreven die elke minuut als cronjob wordt uitgevoerd om te kijken of de kaart een foutmelding gegenereerd heeft, zo ja: automatisch resetten.
 

Echter, aan de log file te zien lijkt de vooruitgang juist achteruit te zijn gegaan gezien hij nu minder ver komt dan eerst..

  • reader) ziggo [smargo] creating thread for device /dev/ttyUSB0
  • 2018/01/26 22:09:02 5F2D0334 r (reader) ziggo [smargo] Buffers readed 0 bytes total time_us 75480
  • 2018/01/26 22:09:02 5F2D0334 r (reader) ziggo [smargo] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz= AUTO, cardmhz=600)
  • 2018/01/26 22:09:02 5F2D0334 r (reader) ziggo [smargo] card detected
  • 2018/01/26 22:09:10 5F2D0334 r (reader) ziggo [smargo] Error activating card.
  • 2018/01/26 22:09:27 5F2D0334 r (-) -- Skipped 2 duplicated log lines --
  • 2018/01/26 22:09:27 5F2D0334 r (reader) ziggo [smargo] THIS WAS A FAILED START ATTEMPT No 1 out of max alloted of 1
Edited by xorinzor
Link to comment
Share on other sites

(kan mn bericht niet meer bewerken, dus moet een nieuw post maken)

Een reboot heeft het probleem van het logfile hierboven opgelost, inmiddels doet mijn scriptje wat ik er van verwacht heb en lost deze automatisch het reader probleem op (ookal kost dit soms 3 pogingen).

Ideaal is het niet, maar beter dan niks zou ik zo denken haha.

deprecated=1 lijkt dit proces ook nog iets te hebben versneld gezien ik aan de log files kon zien dat de normale modus nooit werkte en pas werkte nadat overgegaan was naar de deprecated modus.

Edited by xorinzor
Link to comment
Share on other sites

13 uur geleden zei henkvd1:

Heb dit wel vaker gezien, speel eens met MHz en card MHz in je reader   verlaag MHz naar 540

 

Dit lijkt te hebben geholpen! Krijg nu bij elke restart van de reader direct een succesvolle initialisatie.
Wel zegt hij alleen dat irdeto kaarten 600mhz moeten hebben (en voor zover mij bekend is de kaart die ik heb idd een irdeto kaart, zo'n oranje ziggo smartcard). Echter, als ik cardmhz weer terug naar 600 zet werkt het weer eens in de zoveel keer.

Kan het problemen opleveren om de kaart op 500mhz uit te lezen?

EDIT: te vroeg gesproken, het probleem doet zich inmiddels weer voor

Log:

2018/01/27 12:13:55 4691407C r   (reader) ziggo [smargo] Buffers readed  0 bytes total time_us 75468
2018/01/27 12:13:55 4691407C r   (reader) ziggo [smargo] Reader initialized (device=/dev/ttyUSB0, detect=cd, mhz=480, cardmhz=480)
2018/01/27 12:13:56 4691407C r   (reader) ziggo [smargo] card detected
2018/01/27 12:14:04 4691407C r   (reader) ziggo [smargo] ATR: 3B 9F 21 0E 49 52 44 45 54 4F 20 41 43 53 20 56 35 2E 37 9A 
2018/01/27 12:14:04 4691407C r   (reader) ziggo [smargo] Init card protocol T14, FI=2, F=558, D=1, N=0
2018/01/27 12:14:04 4691407C r   (reader) ziggo [smargo] Calculated work ETU is 77.50 us reader mhz = 480
2018/01/27 12:14:05 4691407C r   (reader) ziggo [smargo] ATR Fsmax is 5 MHz, clocking card to wanted user cardclock of 4.80 MHz (specified in reader->mhz)
2018/01/27 12:14:06 4691407C r   (reader) ziggo [smargo] detect irdeto card
2018/01/27 12:14:06 4691407C r   (reader) ziggo [smargo] Irdeto SC 57 version 12 revision 1, patch level e
2018/01/27 12:14:06 4691407C r   (reader) ziggo [smargo] caid: 0604, acs: 6.08, country code: NLD
2018/01/27 12:14:06 4691407C r   (reader) ziggo [smargo] providers: 4, ascii serial: ##########, hex serial: ######, hex base: ##
2018/01/27 12:14:11 4691407C r   (reader) ziggo [smargo] WARNING: For Irdeto cards you will have to set 'cardmhz= 600' in oscam.server
2018/01/27 12:14:11 4691407C r   (reader) ziggo [smargo] active providers: 4 (0c0bb4,006900,006900,006900)
2018/01/27 12:14:11 4691407C r   (reader) ziggo [smargo] found card system irdeto
2018/01/27 12:14:11 4691407C r   (reader) ziggo [irdeto] THIS WAS A SUCCESSFUL START ATTEMPT No  1 out of max alloted of 1

 

Edited by xorinzor
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Lees alvorens je verder gaat onze Terms of Use en Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.