Jump to content
putemmer

Draaiing van een DiSeqC motor – ijking van het aantal pulsen.

Recommended Posts

Enige jaren geleden heb ik mijn draaibare schotel met een DiSeqC motor (in mijn geval een Amiko DM3800) geplaatst en prima afgeregeld (30 West t/m 75 East.

Ik had dus eind Mei 2019 het probleem dat mijn schotel geen ontvangst had na een zware wind.

Ik heb toen de worm wiel in de motor van de schotel stevig aangedraaid zodat de motoras en dus de schotel nagenoeg geen speling meer had.
Daarna had ik het effect dat de motor niet terug kwam op zijn nul positie en heb daarom de motor ‘reset’.
Daarna de schotel nog een heel klein beetje verdraaid te hebben had ik weer dezelfde ontvangst als vroeger 🙂

Bij een stevige wind was zelfs de variatie in SNR duidelijk minder doordat de schotel-as dus aangedraaid was 🙂

Maar ruim een week geleden was er weer een storm en had ik weer geen signaal.

Alle denkbare instellingen bleek nog precies zo te staan zoals ik dat in het begin afgeregeld had.
Vervolgens de schotel weer om de as van de paal verdraaid tot ik weer ontvangst had.
Wat bleek … ontvangst nadat ik hem ongeveer 15 á 20 !!! graden richting west gedraaid had.
Vervolgens de schotel  weer om de paal teruggedraaid naar de originele gemerkte positie waar mijn merktekens staan.

Daarna (net zoals in 2019) de DiSeqC motor ‘reset’ volgens de procedure die in het boekje staat “Hardware Reset by Receiver”.

Daarna had ik weer een excellente ontvangst over het gehele gebied (30West t/m 75East).

Mijn voorzichtige conclusie is dat de DiSeqC motor uit zijn callibratie is gelopen door de wisselende belasting (kracht) in East / West richting (door de storm wind) op de schotel .
Ik weet alleen niet of dit juist is.

1      1) Kan me iemand vertellen hoe dat een DiSeqC motor weet en op basis waarvan hij hoeveel draaien moet?

2     2) Kan het zijn dat die (pulsen teller?) door de het op en neer gaan van de schotel door de storm) uit zijn callibratie is geraakt.

Share this post


Link to post
Share on other sites

Volgens mij draait hij gewoon om de mast doordat hij niet goed vast zit. Bijvoorbeeld door een te dunne mast of een matige klem.

Een gat door de klem en in de mast boren, daar een stevige schroef in draaien en je probleem is opgelost.

Share this post


Link to post
Share on other sites

Blijkbaar is het niet duidelijk.

 

Dus hij was helemaal niet verdraaid. Dat kon ik zien aan alle merktekens die ik na de installatie geplaatst had.
ik had hem toch maar verdraaid omdat ik het niet snapte wat er gebeurd was.

 

Achteraf gezien had ik dus beide keren 2019 en 2020 de schotel 'niet 'om de paal hoeven te draaien want pas nadat ik deze precies op dezelfde plaats had teruggezet én daarna de motor had gerest was alles weer prima zoals vanouds.

 

Zo duidelijker? 🙂

Share this post


Link to post
Share on other sites
Posted (edited)

Uitgaande van het idee, dat diseqc 1.2 opdrachten altijd gerelateerd worden aan de 0-positie (zoveel pulsen vanaf de 0 <GotoNn>; zoveel graden vanaf de 0 <GotoX/USALS>), zijn er volgens mij twee mogelijke oorzaken:

1. de motor weet niet meer waar hij is

2. de motor heeft een verschoven 0-positie.

(Hoe dat precies elektronisch gaat, weet ik helaas niet.)

 

Heb je in je aanpassingen eerst een Goto-0/GotoRef geprobeerd? Ging hij dan naar de echte 0, of naar een 15 a 20 graden verschoven positie?

Dat zou de eerste indicatie zijn, welke van de twee bovenstaande situaties aan de hand is.

 

Groet,

A33

Edited by a33

Share this post


Link to post
Share on other sites

Beste A33,

Inderdaad zat ik daar ook aan te denken.
Daarom ben ik nieuwsierig hoe dat electronisch gaat (als dit de oorzaak is geweest).

 

Je schreef:
"Heb je in je aanpassingen eerst een Goto-0/GotoRef geprobeerd? Ging hij dan naar de echte 0, of naar een 15 a 20 graden verschoven positie?":

Nadat ik de Diseqc motor weer precies op de vooraf aangebrachte merkteken op de paal van de regelvoet te gedraaid ben ik naar beneden gegaan en daar de 'Hardware reset by Receiver' volgens het boekje uitgevoerd.

 

Deze luid:
1. Excecute the command: Go to reference (Go To '0');

2. Cut off the power by disconnecting the coaxial cable;

3. Reconnect the coaxial cable;

4. Execute the command : Shift '0';
5. Then, its memory erased, the rewrites the satelliets table to initial one and corrects the "0".

Opm.: Na handeling 1. had ik al beeld en heb de procedure volledig afgemaakt om deze in het geheugen van de motor te verankeren.


*) Na deze procedure was alles 'blijvend' oké en had ik weer beeld. (uiteraard moest ik nog wel de motor van de schotel ietsjes bijdraaien omdat je nooit 100% via de merktekens kan positioneren).

 

 

Share this post


Link to post
Share on other sites
3 uren geleden, putemmer zei:

Opm.: Na handeling 1. had ik al beeld

 

Dat betekent dus dat hij gewoon naar de goede 0-positie terugging.

Het resetten van de 0 is dan dus niet meer nodig; en het resetten van de GotoNn opdrachten ook niet. (Gebruik jij de motor op USALS?)

 

Kennelijk raakte de motor in de war met waar hij is. Na een Goto0/GotoRef weet hij weer waar hij zich bevindt (op de 0, namelijk).

 

Waardoor de motor denkt dat hij wat opgeschoven is, weet ik niet. Elektrische of magnetische pulsen ergens vandaan? Maar of/hoe die ook invloed hebben als er geen spanning op de kabel staat?

 

Bij motorproblemen is een Goto0/GotoRef eigenlijk het eerste wat je moet proberen.

 

Groet,

A33

Share this post


Link to post
Share on other sites

Bij GotoRef draait de rotor naar een vaste mechanische eindschakelaar .

Bij een Stab komend van een oostelijke positie stop de motor direct op deze zero switch (0 punt)

Komend van een westelijke positie , loopt hij een paar graden over het 0 punt heen , keert om en stopt dan op de zero switch , teneinde om altijd op exact hetzelfde punt te stoppen .

Een SG2100 doet dat juist andersom als ik me goed herinner .

De SG2100 e.d. gebruiken voor Usals 38 pulsen / 1º rotoras verdraaing .

Ik vermoed dat het probleem typisch is voor de Amiko  DM3800 , op één of andere manier gaat het tellen niet goed .

Zo te zien heeft deze Amiko maar één HAL sensor t.o.v. de SG2100 types waarbij de sensoren 90º t.o.v. elkaar staan .

Langs die sensoren draait de ronde magneet achter op de electromotor .

Op deze manier kan de electronica bepalen welke richting de electromotor draait en hoeveel omwentelingen / pulsen .

Misschien dat de amiko in de fout gaat bij zeer zwaar draaien en de pulsen op of aftelt in de verkeerde richting , immers een enkele puls overslaan kan bij 38p/1º nooit zo'n grote afwijking geven  .

Ik kan me niet voorstellen dat door bewegen van de schotel door de wind , het wormwiel de wormas laat verdraaien en daardoor ongewild de electromotoras met de magneet .

Tenzij de verende opstelling van het aandrijfblok t.o.v. het wormwiel daar een rol in speelt .

Bij grote winddruk op de schotel zou het blok met wormas tijdens het draaien enigszins naar achter gedrukt kunnen worden en bij het stoppen weer langzaam volledig in het wormwiel zakken en daarbij de wormas inclusief de aandrijving verdraaien , maar ook dit kan nooit in één keer een verschil van 15º opleveren .

Alfred de Witt heeft vergelijkbare problemen ondervonden .

https://www.sat4all.com/forums/topic/349112-amiko-3800-diseqc-motor-en-sab-120cm-schotel/

 

amiko counting.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
21 uren geleden, trust zei:

Ik kan me niet voorstellen dat door bewegen van de schotel door de wind , het wormwiel de wormas laat verdraaien en daardoor ongewild de electromotoras met de magneet .

Tenzij de verende opstelling van het aandrijfblok t.o.v. het wormwiel daar een rol in speelt .

Bij grote winddruk op de schotel zou het blok met wormas tijdens het draaien enigszins naar achter gedrukt kunnen worden en bij het stoppen weer langzaam volledig in het wormwiel zakken en daarbij de wormas inclusief de aandrijving verdraaien , maar ook dit kan nooit in één keer een verschil van 15º opleveren .

 

En als het heen en weer beweegt, is het ook gek dat de sensor het maar één kant op registreert? Of werkt dat anders (ik heb geen verstand van HAL-sensors)?

 

En is het voor het registreren van een verdraaiing dan ook nodig dat er (tijdens de storm) spanning op de motoraansluiting staat, bijv. LNB-spanning in standby? Anders lijkt het me helemaal gek dat de elektronica iets onthoudt.

 

 

21 uren geleden, trust zei:

Bij GotoRef draait de rotor naar een vaste mechanische eindschakelaar .

Ik zat naar aanleiding hiervan nog wel te denken: Wat doet dan een motor reset dan met het nulpunt? Want volgens de diseqc-specs zou een motor reset commando het nulpunt (opnieuw) moeten vastzetten op de huidige positie op dat moment.

Werkt de soft-0-positie niet, bij een motor met harde 0-positie-schakelaar?

En/of zijn sommige motoren uitgerust met een harde 0-positie (schakelaar), en andere weer met een softe 0-positie (vastgelegd met het reset-commando)?

 

 

Ik vraag me dus af, net als putemmer, hoe dit nu werkt en hoe het veroorzaakt wordt.

 

Groet,

A33

Edited by a33

Share this post


Link to post
Share on other sites

Even wat gegoogled:

 

B.J./wejones heeft ook al eens wat getest zo te lezen, maar helaas nog zonder duidelijke conclusies:

https://www.satelliteguys.us/xen/threads/zero-position-on-sg2100.230224/

 

In deze (latere) post beschrijft hij echter, dat Goto-0 ook als een Goto-X commando voor 0 graden gegeven kan worden, met gebruik van de soft-zero:

https://rickcaylor.websitetoolbox.com/post/show_single_post?pid=1290999900&postcount=7&forum=409261

Zit daar een verschil?

 

Groet,

A33

 

 

 

Share this post


Link to post
Share on other sites

Bij tot nu toe alle diseqC motoren die ik open heb gehad , heb ik een mechanische Nulpunt schakelaar gezien .

Als je met een SG2100 een GotoRef commando geeft , draait hij naar dat Nulpunt en berekent alle Usals posities vanaf dat punt .

Ik heb niet de mogelijkheid kunnen vinden voor een Goto0 commando maar als je softwarematig een afwijkend nulpunt hebt gekozen , zul je met dat commando telkens terug kunnen naar dat punt . Maar zodra er een GotoRef commando is verwerkt vervalt dat softwarematige punt lijkt me .

Ik denk dat Goto0 en GotoRef , 2 verschillende dingen zijn , ik kan dat hier niet kontroleren daar ik de testen doe met de maxplus 2100 en de Clarke-tech 5000 .

Beide hebben dezelfde menu structuur .

Bij Motor Control in Usals kan ik kiezen : Goto Reference - set W limit - set E limit - Enable limit - Disable limit  en save .

Bij Motor Control in DiseqC 1.2 Goto Reference - set W limit - set E limit - Enable limit - Disable limit - save - Recalculate en Reset system .

Als ik de positie HB in 1.2 op een willekeurige positie vastleg , een GotoRef uitvoer en daarna bij Go To op OK druk , draait hij daar weer naar toe .

Daarna weer GotoRef gedaan en op dat punt Reset system gedaan maar na drukken op Go To had ik verwacht dat de HB uit het geheugen zou zijn .

Niet dus , hij draaide gewoon weer naar die ingestelde positie , toen op die positie een Reset system gedaan , ogenschijnlijk gebeurd er niets , de rotor blijft staan 

 maar ook toen wist hij vanaf het Nulpunt weer de HB te vinden , dus die functie  Reset system is mij ook niet duidelijk .

Ik meen ook ooit gehoord te hebben dat standaard in DiseqC 1.2 mode , de sat posities ook al voorgeprogrammeerd zijn , dus maar eens een nieuwe Technirotor uit de doos gehaald .

Standaard staan ze bij aflevering op 0 , na aansluiten en in diseqC 1.2 en HB gekozen , draaide hij naar ±13º oost op de motorschaal ,

dat klopte al niet want vanaf mijn locatie moet dat ± 10º zijn .

Vervolgens Astra 19.2 gekozen , verrassenderwijs draaide hij nu naar ± 13º west , Astra 28.5  bracht hem weer op ± 28.5º oost .

Op meerdere satellieten kwam de uitkomst ongeveer overeen met de schaal , zowel met de juiste Lat Lon settings in het Usals  menu als met allemaal nullen daar .

Op sommige gekozen satellieten kwam geen reactie , het lijkt of er een soort test programma in zit .

Dat verhaal van B.J./wejones geeft weinig houvast omdat er ook problemen met het geheugen van de rotor waren .

 

 

motor menu.jpg

Share this post


Link to post
Share on other sites

Bedankt voor de analyses 🙂

Ik kan nog maar een ding toevoegen wat mogelijk  nog iets kan betekenen.

 

In 2019 heb ik dit dus ook gehad.
Toen had ik ook erg veel speling op de schotel , dus de as van DiSeqC motor.
Hiervan heb ik hier een video gemaakt en kan je hier bij WeTranfer, bekijken.(wordt daar verwijderd op 18 maart).
Zie:
https://wetransfer.com/downloads/f38f4455e55ccdd95e8721a747c1fc5b20200311195124/7b44c5cfbb4ebf192010eb5ac846906e20200311195200/35cc39

 

Daarna heb ik zoals je kan zien op de video de speling hier weer verwijderd door deze aan te draaien met de inbussleutel.

 

Na de recente stormperiode 2020 bleek de speling dit keer maar heel klein. Die na de storm van 2019 (Video) was veel groter.

Share this post


Link to post
Share on other sites

De Motor Reset en de harde en zachte 0-positie blijft dus voorlopig nog wat onduidelijk.

 

Op 10-3-2020 om 23:52, trust zei:

Bij tot nu toe alle diseqC motoren die ik open heb gehad , heb ik een mechanische Nulpunt schakelaar gezien .

OK, dat is dan duidelijk.

Maar ik blijf me dan afvragen, waarvoor dient dan dat soft-nulpunt? B.J./wejones kreeg het (soms?) voor elkaar, om het nulpunt op een andere plaats te krijgen;

en ik heb al vaker gelezen dat de reset op het echte nulpunt problemen met een 'verschoven arc' liet oplossen...

Gek hoor!

 

23 uren geleden, trust zei:

Ik denk dat Goto0 en GotoRef , 2 verschillende dingen zijn

Ik heb nog niet eerder over een onderscheid tussen de twee gelezen. In de stukken van Eutelsat over diseqc (bijv paragraaf 3.8 hier: https://de.eutelsat.com/files/live/sites/eutelsatv2/files/contributed/satellites/pdf/Diseqc/associated docs/position_app_note_v1.pdf  )

is Positie 0 / due south het referentiepunt. Vooralsnog houd ik ze voor hetzelfde.

 

Op 10-3-2020 om 23:52, trust zei:

Ik meen ook ooit gehoord te hebben dat standaard in DiseqC 1.2 mode , de sat posities ook al voorgeprogrammeerd zijn

Dat klopt volgens mij. Maar verschillende fabrikanten hebben wel hun eigen lijstjes gemaakt en soms eigen volgorden, heb ik ooit in sommige manuals gezien.

 

 

Misschien is ook hier het diseqc 1.2 protocol niet helemaal eenduidig ingevoerd (de eutelsat stukken zijn uit 1998, en later niet bijgehouden of bijgewerkt); net als de verschillen met GotoX-commando's die jij ook eens (voor mij) getest hebt. Dat is voor de praktijk natuurlijk wel lastig!

 

Groet,

A33

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Onze Terms of Use en Privacy Policy