Ga naar inhoud

OSCAM moet herstarten na elke kanaal wissel?


 Delen

Ga naar oplossing Opgelost door Gast Mimisiku,

Aanbevolen berichten

Hallo allemaal,
na de actie van tvv van 26 juni zat ik op een zwart scherm te kijken.
Het lukte me niet om met de oude OSCAM (v6.5.2) weer beeld te krijgen.
Abo TVV was betaald, hun helpdesk gebeld, zelf 100 keer reactivatie gedaan, niks hielp.
Dan maar de meest recente OSCAM geinstalleerd die ik kon vinden (v11271)
Terug beeld, alleen moet ik nu iedere keer dat ik een andere zender kies de cam herstarten om terug beeld te hebben.
OSCAM downgraden naar v11233 maakt geen verschil, wat me doet vermoeden dat het een misconfiguratie van mij is.
Heeft iemand ooit zoiets gezien?
Thanks, am.
 
De OSCAM loopt in een dm8000 met Gemini Project erin.
 
Dit zijn de config files:
oscam.conf:
 
[global]
disablelog = 1
disableuserfile = 1
unlockparental = 1
nice = -1
preferlocalcards = 1
 
[dvbapi]
enabled = 1
au = 1
boxtype = dreambox
user = dvbapiau
reopenonzap = 1
 
[webif]
httpport = 81
httpuser = admin
httppwd = admin
httprefresh = 20
httpallowed = 127.0.0.1,150.45.87.0-150.45.87.253
httphelplang = en
 
 
oscam.user:
 
# is needed for au
[account]
user = dvbapiau
pwd =
description = lokaal
group = 1
au = 1
betatunnel = 1833.FFFF:1702,1834.FFFF:1722
cccreshare = 0
 
# for using mpcsmon
[account]
user = usermonitor
pwd = password
disabled = 0
group = 1
uniq = 1
sleep = 0
monlevel = 4
 
 
oscam.server:
 
[reader]
label = Boven
description = TV Vlaanderen
protocol = internal
device = /dev/sci1
services = tvv
caid = 0100
detect = cd
mhz = 357
cardmhz = 500
group = 1
emmcache = 1,1,15,0
lb_weight = 1000
ratelimitecm = 4
ratelimitseconds = 10
auprovid = 00006C
 
[reader]
label  =  Onder
protocol  =  internal
device  =  /dev/sci0
caid  =  0100
detect  =  cd
mhz = 357
cardmhz  =  500
group  =  1
emmcache  =  1,1,15
lb_weight = 1000
ratelimitecm = 4
ratelimitseconds = 11
 
 
oscam.dvbapi:
 
P:0100:00006c   #Verwijder deze regel als je CDS NL hebt!
I:0622
I:1817
I:1818
I:1819
 

 

Link naar bericht
Delen op andere sites


tja ik heb geen Gemini Project

of probeer voorlopig ccccam 2.30

of steek je kaart eens in de andere sleuf

anders zou ik eens een andere soft proberen in de dream 8000..waar die cam wel blijft werken  ;) 

keuze genoeg

aangepast door smetje limb.BE

1x Dreambox 900UHD OpenPLi GCC-11.1.20210808 2x  TRIAX 110 TDS 4x twin lnb 1x Channel Master 1.20

1x DREAMBOX 8000 HD pvr 1x DB800 prv  2x Dreambox 800se  1x GIGABLU HD QUADPLUS  1x Sab unix triple

1x Samsung UE65MU7070 4K Ultra HD Smart LED  1x Samsung  UE46F6650SSXXN led 

 

Link naar bericht
Delen op andere sites

Ik zou openatv  of openpli eens proberen, die word nog ondersteund

Vu+duo 4K  openatv 6.4 1TB HDD sat&kabel + Vu+duo2 openatv 6.4 1TB HDD sat&kabel 

Zgemma H9.2H SE 4K openatv 6.4  + Android sat&kabel
Wavefrontier T90. Titanium TQS Universal quad LNB's

Nvidia Shield Android 9 + H96 PRO 4K android 7

Link naar bericht
Delen op andere sites

Ik kan toch uitmaken, dat in zijn config file's, onvolledigheden en/of onjuistheden zijn. Maar ik ben niet bij mijn ontvanger, om te zien, hoe ik het doe. Maar de onderste kaartlezer moet hij group = 1 veranderen naar 2. Nu verwijst hij beide kaartlezers naar dezelfde group, en bij user, zal hij beide kaartlezers aanspreken, wat problemen geeft.

 

[reader]
label  =  Onder
protocol  =  internal
device  =  /dev/sci0
caid  =  0100
detect  =  cd
mhz = 357
cardmhz  =  500
group  =  1 die 1 veranderen naar 2
emmcache  =  1,1,15
lb_weight = 1000
ratelimitecm = 4
ratelimitseconds = 11
 
En aangezien je maar 1 kaart gebruikt, kan je deze lezer disabled zetten, maar ken het commando niet van buiten.
reden edit: spelfout
aangepast door sattv4iedereen

Ontvangst hotbird met tivusat kaart via de vu zero 4K.cd riant (tijdelijk enkel de tv app).tvv sat en antenner via tv. telenet met de telenet box, en een vu uno 4k dvb-c fbc tuner met ci+ (tv met een kaartje).Informatie die ik geef, gaat over de Belgische situatie, tenzij anders vermeld|

Link naar bericht
Delen op andere sites

Bedankt voor de tip voor de server file, ik heb bij de onderste  kaartlezer group = 2 gezet, maar het geeft geen verschil.

Ik aarzel een beetje om de complete image te vervangen, GP werkte prima al jarenlang en ze hebben een goeie rustige skin zonder psycho kleuren.

Sattv4iedereen, je schreef dat er onvolledigheden en/of onjuistheden in mijn config zitten.

Bedoel je dat er meer mis is dan alleen de group in oscam.server?

Thanks, am.
Link naar bericht
Delen op andere sites

Volgens mij is dit weer een gevalletje van copy/paste.

 

In [dvbapi] ontbreekt een belangrijke parameter, enwel pmt_mode. Ik snap niet hoe die er niet in kan zitten:

 

[dvbapi]
enabled                       = 1
au                            = 1
pmt_mode                      = 0
user                          = dvbapiau
read_sdt                      = 2
write_sdt_prov                = 1
boxtype                       = dreambox
 
Die 2de reader kan je op disable zetten als er geen kaart in zit. (Groep maakt niet uit zoals je zelf al ondervonden hebt).
 
Verder kan ik je aanraden om eens rustig het volgende draadje door te lezen: https://www.sat4all.com/forums/topic/343385-home-sharing-oscam/
Link naar bericht
Delen op andere sites

Indien 'pmt_mode' ontbreekt, gebruikt oscam automatisch de standaard waarde.

Deze is '0' voor 'pmt_mode'.

 

Ik vraag me wel af of de 'reopenonzap=1' geen roet in het eten gooit.

Deze word normaal nooit gebruikt.

Ook de 'betatunnel=' lijkt me niet standaard voor een C+NL kaart, maar eerder iets voor oude duitse Sky kaartjes.

 

Bij normaal gebruik zou ook het hele oscam.dvbapi bestand niet nodig zijn.

 

Wellicht is het beter om alle configuratie bestanden te verwijderen en een standaard van bijvoorbeeld @mimisiku te gebruiken?

Link naar bericht
Delen op andere sites

Dan maar de meest recente OSCAM geinstalleerd die ik kon vinden (v11271)

Terug beeld, alleen moet ik nu iedere keer dat ik een andere zender kies de cam herstarten om terug beeld te hebben.
OSCAM downgraden naar v11233 maakt geen verschil, wat me doet vermoeden dat het een misconfiguratie van mij is.
Heeft iemand ooit zoiets gezien?
Thanks, am.
 
De OSCAM loopt in een dm8000 met Gemini Project erin.

Volgens mij staat er iets niet goed in jouw oscam opstartscript "oscam_cam.sh"

staat in de map /usr/script/

en de Attributes van oscam_cam.sh moet 755 hebben (chmod 755)

#!/bin/sh
CAMD_ID=1797
CAMD_NAME="OSCam"
CAMD_BIN=oscam
INFOFILE_A=ecm0.info
INFOFILE_B=ecm1.info
INFOFILE_C=ecm2.info
INFOFILE_D=ecm3.info
#Expert window
INFOFILE_LINES=1111111111000000
#Zapp after start
REZAPP=0
########################################
logger $0 $1
echo $0 $1
remove_tmp () {
  rm -rf /tmp/*.info* /tmp/*.tmp*
}
case "$1" in
  start)
  remove_tmp
  /usr/bin/$CAMD_BIN &      
  ;;
  stop)
  killall -9 $CAMD_BIN 2>/dev/null 
  sleep 2
  remove_tmp
  ;;
  *)
  $0 stop
  exit 0
  ;;
esac
exit 0
aangepast door satmaat
Link naar bericht
Delen op andere sites

Ik heb de [dvbapi] overgenomen van beeheap, maar het maakt compleet geen verschil.

Iedereen lijkt te denken dat ik die tvv kaart share met een andere box, dat is dus niet zo. 

Meestal is de box zelfs helemaal niet met een ip netwerk verbonden.

Het valt me op dat nadat ik naar een ander kanaal zap, de webif niet meer responsive is, ook LiveLog stopt tot ik de cam restart.

 

Ik probeer die standaard config van @mimisiku te vinden, altijd beter om een werkende bestaande oplossing te gebruiken dan zelf het wiel opnieuw uit te vinden. 

 

@satmaat

Permissions van het start-up script staan op 755:

root@dm8000:/usr/script# ls -l os*
-rwxr-xr-x    1 root     root         2856 Jul  6 17:32 oscam_11271_cam.sh
-rwxr-xr-x    1 root     root         2856 Mar 10  2012 oscam_6.5.02_cam.sh
 
Bedankt voor alle hints,
am.
 
Link naar bericht
Delen op andere sites

Als je de firmware kan backuppen zou ik eens (al is het om te testen) een andere image plaatsen, en zo weinig mogelijk in de oscam config bestanden zetten.  Hier staan wel werkende standaard basis oscam config file's. Gebruik ook betrouwbare oscam bin builds. Eentje die je zelf maakt, of iemand die je vertrouwd, en deze voor U maakt.

Ontvangst hotbird met tivusat kaart via de vu zero 4K.cd riant (tijdelijk enkel de tv app).tvv sat en antenner via tv. telenet met de telenet box, en een vu uno 4k dvb-c fbc tuner met ci+ (tv met een kaartje).Informatie die ik geef, gaat over de Belgische situatie, tenzij anders vermeld|

Link naar bericht
Delen op andere sites

Hallo Satmaat, mijn startup script ziet er zo uit:

 

root@dm8000:/etc/tuxbox/config# cat  /usr/script/oscam_11271_cam.sh 

#!/bin/sh

########################################

###### Powered by The Gemini Team ######


########################################

#  camid                               #

#  0000       = Commom Interface       #

#  0001->0099 = for User Experiment    #

#  0177       = Rq-Echo-Client         #

#  0178       = RqCS                   #

#  0179       = RqCamd                 #

#  0189       = OpenCam                #

#  0199       = Dccamd                 #

#  0200->0299 = Fbiss                  #

#  0300->0399 = Camd3                  #

#  0400->0499 = Camx                   #

#  0500->0599 = Camx-Radegast-CS       #

#  0600->0699 = Evocamd           -OLD #

#  0700->0799 = Evocamd_ronlad_cs -OLD #

#  0800->0899 = Mgcamd            -OLD #

#  0900->0999 = Mgcamd_ronald_cs  -OLD #

#  1000->1099 = Newcamd           -OLD #

#  1100->1199 = Newcamd-ronald_CS -OLD #

#  1200->1299 = Newcamd-spider    -OLD #

#  1300->1399 = Radegast               #

#  1400->1499 = Ronald-CS              #

#  1500->1599 = Scam                   #

#  1600->1699 = Scam-Ronald-CS         #

#  1700->1799 = OSCam                  #

#  1800->1899 = NewCS                  #

#  2000->2099 = Camd3                  #

#  2300->2399 = Camd3-NewCS            #

#  2600->2699 = Camd3-MPCardserver     #

#  3000->3099 = Evocamd                #

#  3100->3199 = Evocamd-Ronald-CS      #

#  3200->3299 = Evocamd-NewCS          #

#  3300->3399 = Evocamd-MPCardserver   #

#  4000->4099 = Mgcamd                 #

#  4100->4199 = Mgcamd-Ronald-CS       #

#  4200->4299 = Mgcamd-NewCS           #

#  4300->4399 = Mgcamd-OSCam           #

#  5000->5099 = Newcamd-Betad          #

#  5100->5199 = Newcamd-Cardserver     #

#  5200->5299 = Newcamd-Spider         #

#  5300->5399 = Newcamd-NewCS          #

#  5400->5499 = Newcamd-OSCam          #

#  6000->6099 = CCcam                  #

#  6100->6199 = CCcam-Capmtserver      #

#  6200->6299 = CCcam-NewCS            #

#  6300->6399 = CCcam-OSCam            #

#  7000->7099 = Mbox                   #

#  7100->7199 = Mbox-NewCS             #

#  9500->9599 = reserved               #

#  9600->9699 = reserved               #

#  9700->9799 = reserved               #

#  9800->9899 = reserved               #

#  9900->9999 = reserved               #

########################################

 

CAMD_ID=1700

CAMD_NAME="oscam 11271"

CAMD_BIN=oscam

 

INFOFILE_A=ecm0.info

INFOFILE_B=ecm1.info

INFOFILE_C=ecm2.info

INFOFILE_D=ecm3.info

#Expert window

INFOFILE_LINES=1111111111000000

#Zapp after start

REZAPP=0

 

########################################

 

logger $0 $1

echo $0 $1

 

remove_tmp () {

  rm -rf /tmp/*.info* /tmp/*.tmp*

}

 

case "$1" in

  start)

  remove_tmp

  /usr/bin/$CAMD_BIN &

  ;;

  stop)

  killall -9 $CAMD_BIN 2>/dev/null

  sleep 2

  remove_tmp

  ;;

  *)

  $0 stop

  exit 0

  ;;

esac

 

exit 0

root@dm8000:/etc/tuxbox/config#

 

Ik heb juist een keer de config van Willy/Kabeltje87 geprobeerd, maar nu blijft het compleet zwart en in de Live Log verschijnt 1 keer per seconde 


  • 2016/07/13 18:14:01 212B6FF0 c (dvbapi) PMT6: Trying connect to enigma CA PMT listen socket...
  • 2016/07/13 18:14:01 212B6FF0 c (dvbapi) socket connect error (errno=2 No such file or directory)
  • 2016/07/13 18:14:02 212B6FF0 c (dvbapi) PMT6: Trying connect to enigma CA PMT listen socket...
  • 2016/07/13 18:14:02 212B6FF0 c (dvbapi) socket connect error (errno=2 No such file or directory)

 



Ik probeer de Mimisiku config nog een keer uit.

Als ook dat niet werkt ga ik voor een nieuwe boot image.

 

@sattv4iedereen ik heb de oscam binary gedownload van


am.

Link naar bericht
Delen op andere sites

Juist de Mimisiku config in /etc/tuxbox/config neergezet.

Opnieuw beeld zolang ik niet van kanaal verander, maar zo gauw ik zap moet de cam herstarten om weer beeld te krijgen.

Het enige dat nu nog niet vervangen is, is de image.

Ik heb wat leeswerk voor de boeg denk ik.

Link naar bericht
Delen op andere sites

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.
Opgelet: Je bericht zal moeten worden goedgekeurd door een moderator alvorens het zichtbaar zal worden.

Gast
Reageer op dit topic

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

 Delen

×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.