Ga naar inhoud

cronjob om ontvanger in standby te zetten


donpedro
 Delen

Ga naar oplossing Opgelost door donpedro,

Aanbevolen berichten

Ben wat aan het stoeien met het opzetten van een cronjob voor een reboot en een standby.

De reboot was vrij eenvoudig, omdat daar gewoon een init.d/reboot voor bestaat.

 

Nu wil ik ook hetzelfde doen voor het standby zetten, alsof ik de standby knop druk op de AB.

 

Blijkbaar is hier dus niet echt een duidelijk genoemd script voor op de box.

Wat ik wel heb heb gevonden is een soort van wget -O /dev/null opdracht die blijkbaar ingrijpt in een script welke binnen de webinterface een newstate triggert.

<div class="powerStateButtons">
\t\t<ul>
\t\t\t<li class="ui-button" onclick="handle_power_state_dialog(new_power_state = 0); return false">''')
        _v = VFFSL(SL,"tstrings",True)['standby_toggle'] # u"$tstrings['standby_toggle']" on line 5, col 97
        if _v is not None: write(_filter(_v, rawExpr=u"$tstrings['standby_toggle']")) # from line 5, col 97.
        write(u'''</li>
\t\t\t<li class="ui-button" onclick="handle_power_state_dialog(new_power_state = 1); return false">''')
        _v = VFFSL(SL,"tstrings",True)['deep_standby'] # u"$tstrings['deep_standby']" on line 6, col 97
        if _v is not None: write(_filter(_v, rawExpr=u"$tstrings['deep_standby']")) # from line 6, col 97.
        write(u'''</li>
\t\t\t<li class="ui-button" onclick="handle_power_state_dialog(new_power_state = 2); return false">''')
        _v = VFFSL(SL,"tstrings",True)['reboot_box'] # u"$tstrings['reboot_box']" on line 7, col 97
        if _v is not None: write(_filter(_v, rawExpr=u"$tstrings['reboot_box']")) # from line 7, col 97.
        write(u'''</li> 
\t\t\t<li class="ui-button" onclick="handle_power_state_dialog(new_power_state = 3); return false">''')
        _v = VFFSL(SL,"tstrings",True)['restart_gui'] # u"$tstrings['restart_gui']" on line 8, col 97
        if _v is not None: write(_filter(_v, rawExpr=u"$tstrings['restart_gui']")) # from line 8, col 97.
        write(u'''</li>
\t\t</ul>
\t</div>

Heeft iemand daar al eens mee lopen stoeien?

VU+ Zero & VU+ Solo2 - VTi 11.x  Unstable Oscam 11xxxx  MacBook Pro Ubuntu 16.04LTS

Link naar bericht
Delen op andere sites


  • Oplossing

In het file root op de locatie /etc/cron/crontabs het volgende geplaatst en het werkt.

05 03 * * * /sbin/reboot
10 03 * * * wget http://127.0.0.1/web/powerstate?newstate=0

Probeerde via VTi cronjob aanmaken de regel te testen, maar toen ontstond er blijkbaar een conflict met het openstaande formulier.

Toen ik hem los ging testen met een tijd erin en dan gewoon TV kijken, bleek het gewoon te werken naar Standby.

 

Opgelost dus. 

  • Like 1

VU+ Zero & VU+ Solo2 - VTi 11.x  Unstable Oscam 11xxxx  MacBook Pro Ubuntu 16.04LTS

Link naar bericht
Delen op andere sites

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.
Opgelet: Je bericht zal moeten worden goedgekeurd door een moderator alvorens het zichtbaar zal worden.

Gast
Reageer op dit topic

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

 Delen

  • Wie is er online   0 leden

    • Er zijn geen geregistreerde gebruikers deze pagina aan het bekijken
  • Gerelateerde inhoud

    • Door tillschweiger
      Hallo, ik heb sinds een week ook een VU+ duo 4KSE (PLI 8.0RC) met 2 S2X (FBC) tuners,  ter vervanging van mijn "overleden" dreambox 8000.
      Ik heb dus aparte losse coaxen die van de LNB afkomen (Quad met multiswitch), maar ik kan niet opnemen en daarna een ander kanaal kijken, krijg dan de melding afstemmen mislukt.
      Het vreemde is wel dat ik bij signaalzoeker op tuner A een goed signaal heb en op tuner B maar even signaal heb en daarna wegvalt, aan de kabel ligt het niet, kabel gewisseld, fout blijft op tuner B. Is hier de tuner al defect? Bij de informatie zie ik gedetecteerd tuners:
      Tuner A-H  Vuplus DVB-S NIM(45308) (DVB-S2X) en
      Tuner  I - P  Vuplus DVB-S NIM(45308) (DVB-S2X)
       
      Groetjes,
      Rob
       
    • Door snuggles123
      New VTi - Vu+ Team Image - VTi 15.0.x



      From VTi Team
      VTi Panel (Blue Button)

      Supported languages:
      English, German, Dutch, Italian, Turkish, Danish, Polish,
      Russian, Ukrainian, Czech, Arabic, French, Swedish,
      Portuguese (Portugal), Greek, Bulgarian, Hungarian

      With modular, flexible VTi skins
      VTi Bootlogos and Radiomode Logo.
      Short press on blue button opens VTi Panel, long press opens Pluginmenu
      Support for FTDI chipset cardreader like smargo and easymouse2
      Running Softcam shown in the Infobar
      MovieList with extended functions
      Support for full image backup and restore (not Vu+ Solo 4K / Uno 4K)
      Supports VTi image flash online (not Vu+ Solo 4K / Uno 4K)
      Restore Plugins, Bouquets, Settings, etc. during installation
      Remove preinstalled packages during installation (VTi Zero)
      Support delayed descrambling in standby (Solo 4K, Uno 4K, Uno4K SE, Ultimo 4K, Zero 4K, Duo4K SE ,Duo 4K)
       
    • Door sattv4iedereen
      Hi,
      zijn er ergens picons voor de Belgische telenet kabelzenders?
      Na een zoektocht, heb ik ze (nog) niet gevonden.
    • Door Anoniem
      Ik wil graag de Hanssettings op mijn Zero zetten. Image is VTi 13.0.12. In de feed op de box zie ik geen Hanssettings, wel een stuk of 5 lijsten voor Astra 1. Ik heb verder geen Windows, maar wel Ubuntu en FTP.
    • Door dirk044
      Sinds ik mijn VU+Solo4K heb geflasht met OpenPli 7.3 zijn er een aantal dingen veranderd,
      zoals de symbolen die worden weergegeven bij een zender.
      Bij een UHD zender geeft hij nu ook 4K weer in het rechter symbool waar nu HD staat. 
      Wat betekenen de andere symbolen, vooral de gekleurde?

    • Door Denisdaf
      OpenPli 4.
      VU plus Solo 2 en Duo 2.
      Ik wil graag de naam van de interne schijven veranderen.
      Hoe kan ik dat zonder dat deze er uit moeten worden gehaald natuurlijk?
       
      Alvast bedankt
    • Door hiburg
      Hallo,
       
      Sinds een aantal maanden gebruik ik een VU+ Uno 4K SE met dubbele DVB-S aansluiting, tot volle tevredenheid.
      Ik maak dagelijks opnames via de timer , kijk ze veelal af via de Ipad via Infuse. Er lopen twee coaxkabels vanaf de Triple LNB naar de ontvanger.
       
      Alleen een enkele keer gaat de opname mis: hij staat dan als 0 bytes als grootte in de opnamelijst en deze is dan niet af te spelen.
      Ik gebruik als image VTI.
       
      Iemand een idee waar dit aan zou kunnen liggen ? Ik wil de harde schijf niet formatteren omdat ik dan al mijn opnames kwijt ben, een optie om het bestandssysteem te kunnen herstellen heb ik nog niet kunnen vinden in VTI.
       
       
       



×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.