Ga naar inhoud

CI+ module i.c.m. OpenPLi


 Delen

Aanbevolen berichten

Ik gebruik al een tijdje VTi om mijn SmarDTV CI+ module van Telenet te gebruiken i.c.m. een Vu+ Duo2.
Ik maak echter toch liever gebruik van OpenPLi, maar lees her en der (ook op dit forum) dat CI+ en OpenPLi niet (meer) samenwerken.

Out of the box - op een maagdelijke OpenPLi image - is dit ook zo, maar ik wou hier graag delen hoe het toch mogelijk is om een CI+ module van Telenet werkend te krijgen op een receiver met OpenPLi.

Het zou handig zijn mocht je laten weten welke receiver/module-combinatie jij aan de praat kreeg op OpenPLi.

 

screenshot_20210802103319.thumb.jpg.e8154aff712230608cdb03c67a0cba04.jpg


Hoewel ik hiermee bevestig dat dit nu werkt, is het vanzelfsprekend geen garantie dat dit ook zo zal zijn in de toekomst.

Al wat je nodig hebt is een plugin die te downloaden is op github.com/Ednaz/e2binary, maar lees eerst verder hieronder omdat de plugin mogelijks eerst een kleine aanpassing op jouw ontvanger vereist.


Het zou moeten werken op de ontvangers uit het lijstje hieronder waarvan ik persoonlijk de werking op de Vu+ Duo2 kan bevestigen i.c.m. OpenPLi 8.0.
Ook nog even vermelden dat dit niet werkt op een Vu+ Duo 4K SE.

 

  • gi et11000
  • formuler4turbo
  • gbquad4k
  • gbue4k
  • lunix3-4k
  • lunix4k
  • vuduo2
  • vuduo4k
  • vusolo2
  • vusolo4k
  • vusolose
  • vuultimo4k
  • vuuno4k
  • vuuno4kse
  • vuzero4k

 

Om de plugin foutloos zijn werk te laten doen heb je de juiste versie van de functie 'wget' nodig. Op mijn Vu+ Duo2 staat standaard de BusyBox-versie (een light-versie met minder opties) waardoor de plugin bij mijn eerste pogingen de mist in ging.

 

Zoek het ip-adres van je ontvanger op en start een Telnet-sessie

 

opkg update
opkg install wget


Nu zou alles goed moeten zijn om de plugin te installeren via een Telnet-sessie of lokaal via de ontvanger.

Zet de plugin eerst op een toegankelijke locatie, bijv. op een USB-stick.

Mijn voorkeur gaat naar een Telnet-sessie omdat je bij eventuele fouten direct de foutmeldingen ziet:

 

opkg install /media/usb/enigma2-plugin-systemplugins-ciplusinstall_1.8-r1-openpli_7.0-release_7.1-release_7.2-release_8.0-release_all.ipk


Lokaal installeren met de afstandsbediening kan ook:


MENU-toets > Applicaties > Softwarebeheer > Installeer plugins lokaal > /media/usb > Installeer applicaties > selecteer de plugin, vink aan en installeer met de groene toets.

 

Na installatie van de plugin wordt de ontvanger automatisch herstart.

Als je vervolgens een kanaal selecteert dat de CI+ module nodig heeft om het signaal te decrypteren wordt de module gekoppeld met de ontvanger.

 

1_0_19_900_17_1_FFFF0000_0_0_0_20210802103949.thumb.jpg.c228406ae67b1bd4cad4fbe59a05dc88.jpg

 

1_0_19_900_17_1_FFFF0000_0_0_0_20210802103957.thumb.jpg.a4477d872257d8f7d28c043668a42b40.jpg

  • Like 2
Link naar bericht
Delen op andere sites


  • Reacties 134
  • Aangemaakt
  • Laatste reactie

Beste reacties in dit topic

Beste reacties in dit topic

Populaire berichten

Eventjes recapituleren voor wie nu pas inpikt, want in dit topic worden eigenlijk 2 methodes door elkaar heen behandeld.   Methode 1 (Ednaz - zie 1ste post van dit topic) Enkel voor

Als je de oplossing niet wilt delen, voor wat voor reden dan ook.  Houdt dan Uw mond.  Reageer niet. Melden (want daar komt het op neer) dat je de oplossing weet, maar ze niet wil delen (zoals ge

Ik gebruik al een tijdje VTi om mijn SmarDTV CI+ module van Telenet te gebruiken i.c.m. een Vu+ Duo2. Ik maak echter toch liever gebruik van OpenPLi, maar lees her en der (ook op dit forum) dat CI+

Geplaatste afbeeldingen

  • V.I.P.

Getest op een Galaxy 4K en een VU+Ultimo4K i.c.m. een Ziggo Quantis 1.3 module.

 

Werkt in beide gevallen niet (goed)..

 

Installeert zonder foutmelding.. Na een herstart decodeert hij 1 kanaal (waar hij mee start). Na een zenderwissel komt steevast de melding “uw tv herkent de module niet”

Wel geeft de module de smartcard info, maar geen beeld..

 

Bij NPO1 HD komt geen authorisatie scherm, ook niet na herinsteken van de module..

Raspberry Pi 3B+ Argolis Triple Reader Kaartserver + Smargo

Vu+ Zero 4K DVB-S2X, Vu+ Zero 4K DVB-C/T2, DM525 Combo, DM920 UHD

VU+Ultimo4K BTE, Ziggo, HD+, TV-Vlaanderen, ORF

13°E,19.2°E, 23.5°E, 28.2°E. Triax 88 en Triax 60

Link naar bericht
Delen op andere sites

Op 3-8-2021 om 12:21, Zilverhippie zei:

Nog even toevoegen dat ik ben vertrokken van een clean install van OpenPLi zonder andere plugins, oscam, etc...

 

De vraag is eigenlijk, doet die het na het zappen nog?   Zo ja dan zal er waarschijnlijk bij mimisiku een instelling verkeerd staan. 

SCHOTEL: 1,2 Mtr 50E-55W / 60cm Astra 19/23 / Airspy R2 SDR 24-1800 Mhz
RECEIVERS: Dreambox DM8000/800SE / VU+ Ultimo 4K Sat & Kabel & DVB-T2 / Rpi2 ADS-B (MLAT) FlightFeeder

IPTV:  KPN 4K IPTV / Android 4K IPTV box / KODI & Netflix / 60 TB SAN / Glasvezel: 500/500 Mbit

Link naar bericht
Delen op andere sites

  • V.I.P.

Wat kan er verkeerd staan?

 

De autorisatie zie ik niet. Geeft beeld op 1 zender en daarna niets...

OScam staat uit en de Common Interface Assignments op CAID 0606.. Meer smaken heb ik niet...

 

Op DreamOS 2.5, Dream-Elite, NewNigma2 komt keurig de autorisatie en werkt alles. Ook na zappen... 

Raspberry Pi 3B+ Argolis Triple Reader Kaartserver + Smargo

Vu+ Zero 4K DVB-S2X, Vu+ Zero 4K DVB-C/T2, DM525 Combo, DM920 UHD

VU+Ultimo4K BTE, Ziggo, HD+, TV-Vlaanderen, ORF

13°E,19.2°E, 23.5°E, 28.2°E. Triax 88 en Triax 60

Link naar bericht
Delen op andere sites

4 uren geleden, Codx zei:

De vraag is eigenlijk, doet die het na het zappen nog?   Zo ja dan zal er waarschijnlijk bij mimisiku een instelling verkeerd staan. 

Ja, hij doet het bij mij na het zappen ook nog.

Vu+ Duo2 / OpenPLi 8.0 / Telenet CI+ module.

 

Met die clean install wou ik alleen maar zeggen dat indien iets niet direct werkt op een systeem dit ook kan liggen aan onderliggende processen die op de één of andere manier interfereren.

Om te testen of deze "ciplusinstaller" überhaupt werkt met jouw receiver/CI+ combinatie kan een clean install de nodige informatie opleveren.

Link naar bericht
Delen op andere sites

  • 2 weken later...

Nee, niet specifiek voor Telenet, maar het werkt wel voor Telenet.

Ik las op een Russisch forum dat de plugin ook werkt voor een Tricolor module.

Geen idee welke Russische provider daarvan gebruik maakt.

Er zullen er wel meer zijn waarvoor het werkt en ook waarvoor het niet werkt. Uitproberen maar en deel jouw kennis.

Link naar bericht
Delen op andere sites

  • V.I.P.

Nog eens getest op een oude VU+SoloSE v2 met een kale OpenPli 8.0. Werktnog steeds niet bij mij. Er komt simpelweg geen autorisatie proces op gang…Het enige wat werkt is het gecodeerde kanaal waar je toevallig op staat afgestemd. De Russische site kan ik niet lezen (er wordt geschreven over plugin.py en wat over attributes)… Wellicht vergeet ik een stap, maar het alleen installeren is bij mij niet voldoende.. 

Raspberry Pi 3B+ Argolis Triple Reader Kaartserver + Smargo

Vu+ Zero 4K DVB-S2X, Vu+ Zero 4K DVB-C/T2, DM525 Combo, DM920 UHD

VU+Ultimo4K BTE, Ziggo, HD+, TV-Vlaanderen, ORF

13°E,19.2°E, 23.5°E, 28.2°E. Triax 88 en Triax 60

Link naar bericht
Delen op andere sites

Het kan natuurlijk ook dat het gewoon niet werkt met een Ziggo module.

Geen specifieke foutmeldingen als je het via Telnet installeert?

Ook toevallig je Vu+ geen andere naam gegeven?

Die Russische site geeft vooral veel verwarring, vandaar dat ik in de eerste post van dit topic alles op een rijtje heb gezet hoe ik het voor mijn Telenet-module heb klaar gekregen.

Link naar bericht
Delen op andere sites

  • V.I.P.

Nee, geen foutmelding en het gekke is dat ik de module info en smartcard entitlements gewoon kan uitlezen… Ik heb de IPK gewoon via de software geinstalleerd, niet via Telnet… Daarna de box herstart……

Raspberry Pi 3B+ Argolis Triple Reader Kaartserver + Smargo

Vu+ Zero 4K DVB-S2X, Vu+ Zero 4K DVB-C/T2, DM525 Combo, DM920 UHD

VU+Ultimo4K BTE, Ziggo, HD+, TV-Vlaanderen, ORF

13°E,19.2°E, 23.5°E, 28.2°E. Triax 88 en Triax 60

Link naar bericht
Delen op andere sites

Ik was ook eerst vertrokken van een kale OpenPLi 8, had vervolgens de ipk via de software geïnstalleerd en geen foutmeldingen gekregen, maar kreeg niets gedecodeerd.

Daarna opnieuw geflasht en het eens geprobeerd via Telnet en daar kreeg ik wel een foutmelding die niet was getoond toen ik de ipk via de ontvanger-software installeerde.

De fout was een gevolg van een verkeerde wget-versie.

Via Telnet krijg je over het algemeen wel meer feedback indien iets fout loopt.

Het is dus wel cruciaal dat je de juiste wget versie hebt, dus via Telnet eerst:

opkg update
opkg install wget

Ik lees dat je voor je laatste test gebruik maakte van een Vu+ Solo SE v2.

Ik zie de Solo SE v2 niet in het lijstje staan, wel vusolose, dus zonder v2.

Ik weet niet of dit kan helpen, maar je kunt altijd eens proberen door te faken dat je een gewone Solo SE hebt door de hostnaam van je Vu+ Solo SE v2 op te zoeken en dit indien nodig te wijzigen naar vusolose.

Dit kan via MENU > Instellingen > Systeem > Expert instellingen > Netwerk > Adapter kiezen > Mountbeheer > Hostnaam wijzigen.

Link naar bericht
Delen op andere sites

  • V.I.P.
27 minuten geleden, KapiteinIglo zei:

Dus in essentie heb je nu de toekomstige heilige graal? Opnemen en kijken met doorspoelen van reclame?

 

dat is al jaren zo met een betere enigma2 receiver en die heilige graal is dus nog nooit gevonden

 

behalve dat doorspoelen van reclame want dat gaat op de zender SBS6 bijvoorbeeld van het Talpa netwerk dan weer net even niet

Force DMaster 1122, Force DMaster 1145, DM7000, DM500, DM800, DM7020, DM7020HD, Vu+ DUO, Vu+ SOLO2, Vu+ Ultimo, Vu+ Utimo4K, Vu+ ZERO4K

Link naar bericht
Delen op andere sites

Doe mee aan dit gesprek

Je kunt dit nu plaatsen en later registreren. Indien je reeds een account hebt, log dan nu in om het bericht te plaatsen met je account.
Opgelet: Je bericht zal moeten worden goedgekeurd door een moderator alvorens het zichtbaar zal worden.

Gast
Reageer op dit topic

×   Geplakt als verrijkte tekst.   Plak in plaats daarvan als platte tekst

  Er zijn maximaal 75 emoji toegestaan.

×   Je link werd automatisch ingevoegd.   Tonen als normale link

×   Je vorige inhoud werd hersteld.   Leeg de tekstverwerker

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen vanaf een URL in

 Delen

  • Wie is er online   0 leden

    • Er zijn geen geregistreerde gebruikers deze pagina aan het bekijken
×
×
  • Nieuwe aanmaken...

Belangrijke informatie

Lees alvorens je verder gaat onze Gebruiksvoorwaarden en Privacybeleid. We hebben cookies geplaatst op je toestel om deze website voor jou beter te kunnen maken. Je kunt de cookie instellingen aanpassen, anders gaan we er van uit dat het goed is om verder te gaan.