Jump to content


Windows 10 folder mounten met OpenATV lukt niet


Loek3000

Recommended Posts

Ik heb OpenATV 6.1 geïnstalleerd. Een map op de pc gedeeld (iedereen, mijn inlognaam die ik gebruik om mij aan te melden op W10)

 

Heb er een screenshot van gemaakt en ook de automounts.xml zet ik hier neer, loginnaam en ww zijn even veranderd voor mijn privacy hier.

 

<mountmanager>
<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>PC</sharename>
   <sharedir>test</sharedir>
   <options>rw,utf8</options>
   <username>hier_mijn_email_adres@gmail.com</username>
   <password>hier_mijn_wachtwoord_voor_windows_aanmelding</password>
  </mount>
 </cifs>
</autofs>
</mountmanager>

 

 

 

Laatste versie W10 is geïnstalleerd 

Firewall heb ik even uitgeschakeld van de router (ziggo) en w10 zelf

image.png

Edited by Loek3000

T90, Mutant HD 51

Link to comment
Share on other sites


ik heb er ook problemen mee gehad deze te mounten, heb het zo opgelost, nieuwe user met paswoord aangelegd met de oude methode (andere Personen o.i.d.(dit is het in het duits) (dus zonder email adres), deze gemounted de ordner vrijgegeven (weet niet wat de term op nederlands is) en het werkte

Dreambox 7080 SSSS, Kathrein Cas90, 3xLNB UAS484, Katrein EXR1708

Link to comment
Share on other sites

Allereerst zet is heel snel die firewall op je modem/router weer aan. Dat heeft niks te maken met deze netwerk mapping.  En gast accounts moet je ook niet maken want die zijn niet nodig.

 

Firewall op Win10 mag je wel tijdens het testen even uitzetten, als je die daarna maar weer aanzet.!

 

In principe moet het gewoon kunnen werken, maar het zijn dat je SMB 1.x of 2.x protocol weer nodig hebt.  Ik meen dat windows 10 dat uitzet tegenwoordig.  kwestie van googlen.   En de username moet in dit formaat   PCNAAM\USERNAME

 

 

Edited by Codx

SCHOTEL: 1,2 Mtr 50E-55W / 60cm Astra 19/23 / Airspy R2 SDR 24-1800 Mhz
RECEIVERS: Dreambox 920 UHD/DM8000/800SE / VU+ Ultimo 4K Sat & Kabel & T2 / Rpi2 ADS-B FlightFeeder

IPTV:  KPN Glasvezel 1 Gbit & IPTV / Android 4K IPTV box / Kodi & Netflix / 100+ TB Storage

Link to comment
Share on other sites

ik doe het even in het duits, Systemsteuerung(systeembeheer o.i.d.),Benutzerkonten (useraccounts)neuer Nutzer....(onder het kastje met user)(add user ??),

andere Personen ,diese PC andere Person hinzufügen(moet iets zijn Pc andere User toevoegen),

ich kenne Anmeldeinformation nicht(staat apart onderaan in display, )

Benutzer ohne Microsoft-Konto (User whitout Microsoft-Account, dan User bijv. dreambox en paswoord bijv paswoord (ik heb alles klein geschreven zodat dit makkelijk per afstandsbediening in te geven is).

Nieuwstart PC,

dan de ordner freigeben in windows (rechter muisklik op ordner).

dan met Openatv mounten via de CIFS methode.

Edited by jocewa

Dreambox 7080 SSSS, Kathrein Cas90, 3xLNB UAS484, Katrein EXR1708

Link to comment
Share on other sites

nou @jocewa ik ga dat eens proberen, is wat puzzelen maar ik ga ervan uit dat het 1ste deel waar je het over hebt in W10 zelf is, volgens mij heb ik alles wel gedaan, het rare is, het lijkt wel te lukken als ik een folder maak in W10 te delen met guest (in mijn geval) maar ik krijg geen bestanden te zien in die folder...

 

misschien is het wel een bug, router problemen of firewall instellingen, maar goed, ik heb alles al uit gezet....

 

is er niet een mount optie via een terminal in te stellen, want mounten lukt via dat menu ook niet.......

T90, Mutant HD 51

Link to comment
Share on other sites

in die folder staan een aantal bestanden:

smb.conf:

# Do not edit this file!
# Only edit smb-user.conf
include = /etc/samba/distro/smb-global.conf

 

smb-user.conf:

## User changes to Samba config go here

## You can overrule the insecure defaults and enforce password
## protected access to shares by uncommenting the following
## line, including the secure settings:

[global]
#       include = /etc/samba/distro/smb-secure.conf


## You can hide and veto access to certain directories, e.g. mount points of
## other boxes in order to prevent round trips through your LAN
## In Samba 4.x this needs to be configured per share:

[Root]
#       veto files = /ThisBox/OtherBox/AnotherBox/YetAnotherBox/
#       hide files = /ThisBox/OtherBox/AnotherBox/YetAnotherBox/

[Harddisk]
#       veto files = /ThisBox/OtherBox/AnotherBox/YetAnotherBox/
#       hide files = /ThisBox/OtherBox/AnotherBox/YetAnotherBox/

 

lmhosts:

127.0.0.1 localhost

 

workgroup kan ik niet maken, hier de instellingen van /etc/enigma2/autotimer.xml

<?xml version="1.0" ?>
<mountmanager>
<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>PC</sharename>
   <sharedir>test</sharedir>
   <options>rw,utf8</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

</mountmanager>

Edited by Loek3000

T90, Mutant HD 51

Link to comment
Share on other sites

Citaat

Der Samba-Server des VTi (3.6.25) kann nur SMB2 und 1
erst ab Version 4.1 geht SMB3 siehe hier: Samba (software) - Wikipedia

bovenstaand gaat over VTI maar ook OpenATV heeft recent een aanpassing van de samba client gehad

indien je ook nog de samba servr hebt geladen is er een iets complexere user config - maar die kunnen we laten voor wat het is indien je geen aanpassingen hebt gemaakt

 

jij hebt Samba 4.0 en moet dus protocol SMB 2 gebruiken om een Windoiws share te kunnen aankoppelen

indien je op windows SMB 1 nog in gebruik hebt gaat dat niet werken

rw,vers=2.0

zou als optie in je mountregel erbij moeten opdat windows weet dat je een veilig client Protocol gebruikt.

altijd na zo een aanpassing de client dus de mutant herstarten

Cadillac Walk

Boz Scaggs

Link to comment
Share on other sites

2 uur geleden zei Tonskidutch:

rw,vers=2.0

 

erbij of in plaats van "rw,utf8"?

 

Vandaar dat het tot dusver niet lukte.....

Had het idee dat het nu zou lukken, want heb het even geprobeerd, is nog niet gelukt, maar ik ga nog het e.e.a. testen.

 

added: kwam ook dit tegen : link (Guest access in SMB2 disabled by default in Windows 10 Fall Creators)

Edited by Loek3000

T90, Mutant HD 51

Link to comment
Share on other sites

Ik heb er maar eens een reeks van gemaakt, box opnieuw opgestart, en ik krijg de lijst te zien van de opgegeven sharenames... maar geen enkele doet het...

 

Wat een gedoe zeg

 

trouwens, de iconen onder mount viewer zijn wel groen (sharenames: "ja" en "pc")

maar als ik er een paar weg haal onder  mount viewer, dan opeens is deze weer rood?????

 

image.png.3b8e2cd6930aa46c74f81956648ce2e6.png

 

<?xml version="1.0" ?>
<mountmanager>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>PC</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>ja</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>pc</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test1</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test2</sharename>
   <sharedir>\\DESKTOP-O1AM8O8\</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test3</sharename>
   <sharedir>/ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test4</sharename>
   <sharedir>\\ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>\\192.168.178.73</ip>
   <sharename>test5</sharename>
   <sharedir>\\DESKTOP-O1AM8O8\ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test6</sharename>
   <sharedir>\\DESKTOP-O1AM8O8\ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test7</sharename>
   <sharedir>\\DESKTOP-O1AM8O8\ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test8</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>Gast</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test9</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>gast</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test10</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>Guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test11</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>Guest</username>
   <password>*</password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test12</sharename>
   <sharedir>ja</sharedir>
   <options>rw,vers=2.0</options>
   <username>Guest</username>
   <password></password>
  </mount>
 </cifs>
</autofs>

<autofs>
 <cifs>
  <mount>
   <active>True</active>
   <hdd_replacement>False</hdd_replacement>
   <ip>192.168.178.73</ip>
   <sharename>test13</sharename>
   <sharedir>test</sharedir>
   <options>rw,vers=2.0</options>
   <username>Guest</username>
   <password>*</password>
  </mount>
 </cifs>
</autofs>

</mountmanager>

Edited by Loek3000

T90, Mutant HD 51

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Lees alvorens je verder gaat onze Terms of Use en Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.